Trying to make my ISO preactivated

Discussion in 'Windows 7' started by LiuBang, Dec 16, 2021.

  1. LiuBang

    LiuBang MDL Junior Member

    Oct 19, 2020
    97
    29
    0
    i was trying to make my own windows 7 ulitmate 64 edited iso img preactivated
    after searching i found the "windows 7 loader 2.2.2 By Daz''
    it works in activating manualy after installation
    but i'm looking for the automatic activation using $OEM$ folder
    i managed to do as some tutorials says but seems i'm doing something wrong i don't know what is it
    i just want someone to check what i did maybe he can find the problem (as shown in the Screeshoot) 1.jpg
    also if there is another activator that makes &OEM& for auto activation i would love if someone mention it to me or send me a link of it
    Note:the script just forces a restart without doing anything tottaly

    and thanks in advance and have a nice day ^_^
     
  2. luzea

    luzea MDL Expert

    Apr 25, 2019
    1,119
    2,307
    60
    Never try to reboot during SetupComplete phase. You said you are doing something wrong, are there any errors or a log file?
     
  3. LiuBang

    LiuBang MDL Junior Member

    Oct 19, 2020
    97
    29
    0
    i didn't reboot or touch anything
    it's just not working and where the log file should be because i don't know ?
     
  4. ExtremeGrief

    ExtremeGrief MDL Addicted

    Jun 2, 2020
    724
    149
    30
    Do you use UEFI OS
     
  5. LiuBang

    LiuBang MDL Junior Member

    Oct 19, 2020
    97
    29
    0
    yes UEFI
     
  6. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    42,141
    76,779
    450
    The info for the $OEM$ folder setupcomplete.cmd is inside the readme.
    For the loader to work on UEFI you need a modded bios with a valid slic.
    Or just install Pro or Enterprise, both can be KMS activated.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Use KMS VL ALL by abbodi1406 $OEM$ method & your OS will be activated via calling it from setupcomplete.
     
  8. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    42,141
    76,779
    450
    No it won't. Ultimate can't be KMS activated.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Hmm :)
     
  10. LiuBang

    LiuBang MDL Junior Member

    Oct 19, 2020
    97
    29
    0
    thanks alot for you help
    sry for late answer was testing some stuff and forgot to answer back (my bad)
    really appreciate your help guys , helps me to understand stuff i don't know
     
  11. CaptainKirk1966

    CaptainKirk1966 Former MDL Guru

    Oct 31, 2009
    2,386
    1,238
    90
    You said you were using UEFI. You also said it worked post-install, but it wouldn't work post-install on UEFI without a slic modded bios. If you do have slic modded bios, try adding a /bios switch to Windows Loader.exe in SetupComplete.cmd
     
  12. LiuBang

    LiuBang MDL Junior Member

    Oct 19, 2020
    97
    29
    0
    i don't have a slic modded bios and i don't even know what it's as i'm not an experienced person in these stuff
    i think i'm just gonna stick with the manual way as it's not something hard to do (just start the program and press on install then press restart)
    thanks for suggesting a solution and i guess i will search around it when i have the time ^_^
     
  13. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    42,141
    76,779
    450
    The loader will not and cannot work (not automated nor manually) on UEFI/GPT installs when there is no valid slic.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. CaptainKirk1966

    CaptainKirk1966 Former MDL Guru

    Oct 31, 2009
    2,386
    1,238
    90
    Yeah, if loader works when run manually, it could be a UEFI/GPT install with a permanent slic, or an MBR install without a permanent slic, or an MBR install with a permanent slic. Only the OP would know, and apparently does not.
     
  15. George King

    George King MDL Expert

    Aug 5, 2009
    1,367
    1,384
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. gailium119

    gailium119 MDL Addicted

    Oct 12, 2021
    713
    352
    30
    try removewat.
     
  17. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    42,141
    76,779
    450
    Yeah, let's corrupt the system some more (it's probably what is used in the first place or something similar):rolleyes:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. CaptainKirk1966

    CaptainKirk1966 Former MDL Guru

    Oct 31, 2009
    2,386
    1,238
    90
  19. erpsterm35

    erpsterm35 MDL Expert

    May 27, 2013
    1,446
    1,097
    60
    #19 erpsterm35, Dec 18, 2021
    Last edited: Dec 18, 2021
    bad idea
    the KB971033 update may invalidate OP's Win7 install after using removewat

    edited 12/18
     
  20. erpsterm35

    erpsterm35 MDL Expert

    May 27, 2013
    1,446
    1,097
    60