Tryng to mod a gateway mx6958 bios..small problem arises

Discussion in 'BIOS Mods' started by gmcbpi, Feb 9, 2010.

  1. gmcbpi

    gmcbpi MDL Novice

    Oct 24, 2009
    10
    0
    0
    Hello, I have on me a gateway mx6958, and it has a phoenix bios. When i first load the bios, it says:
    Header(OEM_ID_OEMTABLE) in BIOSCOD1.rom(x1)
    Pubkey in MOD_4A00.ROM(x1)
    Marker(2.0) (GATEWAYSYSTEM ) in BIOSCOD1.ROM
    ---------------------------------------------------------------
    So, When i choose the manufacturer i choose other since gateway isn't listed.
    Then i choose the lenovo tp-7w-ltp slic.
    Next i choose my rw everything acpi report.
    I then use the lenovo certificate for verification.
    But then a windows pops up saying Pubkey in MOD_4A00.Rom does not match certificate(x1)
    lenovotp-7w-ltp.bin matches certificate.

    So, I'm wondering is it safe to move on or if i try this will i brick the bios?
     
  2. Brainsuck

    Brainsuck MDL Addicted

    Oct 9, 2009
    666
    156
    30
    gateway is acer so use acer
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. gmcbpi

    gmcbpi MDL Novice

    Oct 24, 2009
    10
    0
    0
    But what about the Pubkey not matching? Can I ignore that? Do you mean to use an acer slic and certificate? The phoenix bios tool doesn't have an acer option...
     
  4. gmcbpi

    gmcbpi MDL Novice

    Oct 24, 2009
    10
    0
    0
    #4 gmcbpi, Feb 10, 2010
    Last edited: Feb 10, 2010
    (OP)
    Is it ok if the Pubkey doesn't match?? I heard Dynamic Mod replaces the pubkey so should I do a dynamic mod or keep it at ssv2?
     
  5. gnusman

    gnusman MDL Novice

    Feb 12, 2010
    4
    0
    0
    #5 gnusman, Mar 5, 2010
    Last edited: Mar 7, 2010
    i am having the same issue ("pubkey in mod_4a00.rom does not match certificate") trying to patch a phoenix bios. looks like this pubkey thing has not been nailed down...? anybody tried flashing with this error popping up? would be great to hear some advice on whether can be ignored or should be taken care of... thanks in advance.

    Well, according to the log file:
    ....
    Pubkey found in MOD_4A00.ROM at 0 (matches report)
    ** Pubkey found in MOD_4A00.ROM at 0 replaced
    .....

    And after I have flashed my Samsung Q1 with this modded BIOS I can confirm there was no problems caused by pubkey thing.
     
  6. NoJuan999

    NoJuan999 Experienced SLIC Tool Operator

    Jul 31, 2009
    9,919
    1,932
    300
    The problem is that you just need to leave the certificate box EMPTY until after you modify the BIOS.
    Putting a Certificate in while Doing the Mod can actually cause problems with the mod.
    After you mod the Bios reload the modified Bios and check the certificate with that BIOS.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...