Unable to open hyperlinks

Discussion in 'Windows 8' started by M0rriss0n, Nov 7, 2012.

  1. M0rriss0n

    M0rriss0n MDL Senior Member

    Sep 17, 2011
    318
    96
    10
    #1 M0rriss0n, Nov 7, 2012
    Last edited: Nov 7, 2012
    After disabling IE 10 I get a warning message if opening a hyperlink.
    This appears in all Office 2013 applications.

    " Your organization's policies are preventing us to complete this action for you."

    I want to open hyperlinks with another browser.
    I cannot find a policy that is configured to prevent opening a hyperlink.
    My browser is set as default and the file associations are correct.

    Does anyone know what is wrong?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. M0rriss0n

    M0rriss0n MDL Senior Member

    Sep 17, 2011
    318
    96
    10
    *Bump*

    After more than ten days waiting for some help on this issue, there is not a single reply.

    Update on this matter.

    Found this:

    htt p://answers.microsoft.com/en-us/windows/forum/windows_7-performance/your-organizations-policies-are-preventing-us/94986167-d289-477b-ba57-238472079b32?msgId=43301069-e1e8-49e0-8212-91d9656832ed

    But I have IE disabled.

    And found this:

    htt p://support.microsoft.com/kb/310049

    Also fixes IE, which I have disabled.

    Third and last I found was this:

    htt p://answers.microsoft.com/en-us/office/forum/office_home-outlook/your-organizations-policies-are-preventing-us-from/0ce46a96-7132-4ec4-9722-d8da0fc3e957?msgId=eb23356c-4ee4-4cb5-8f1a-de0e1450a2ed

    Which also fixes IE.

    I have disabled IE because I don't want to use it, but I want to be able to open hyperlinks with the browser of my choice.

    Any help would be appreciated.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,143
    240
    I found this funny behavior also on one of my machines. When I receive a document through outook 2013 containing a hyperlink, I get the same error message. I have set IE10 as default browser (not disabled) but use Firefox for my daily browsing. Other machines with the same W8 enterprise and same office installation from Technet with legal key work with no such issue. I googled but didn't find a solution yet. Fixit tool only works for 2010 but not for 2013 atm.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. M0rriss0n

    M0rriss0n MDL Senior Member

    Sep 17, 2011
    318
    96
    10
    Thanks PaulDesmond for your reply.

    I really start to think that IE rules, even when you have another browser installed.
    If this is the case, the European rules for browser choice is a joke.
    You can choose a browser but not able to use it completely.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,143
    240
    This is not entirely true as I mentioned my finding only on one machine but otheres with exactly same programs like Firefox do not show the error. It must be somewhere in the registry but I didn't find it yet
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Shenj

    Shenj MDL Expert

    Aug 12, 2010
    1,557
    652
    60
    #6 Shenj, Nov 18, 2012
    Last edited by a moderator: Apr 20, 2017
    Run Process Monitor from Sysinternals and track winword.exe or whatever office thing is giving you this error, use a little bit of brain and try to find the Keys that make sense and hopefully also find out why the call ends as fault
    Open your winword.exe (or whatever you have the problem at), open a document that has a url in it, now go back to Process Monitor, add Winword.exe to Filters as Process Name (CTRL+L) or use that Crosshair thing on the toolbar and target word with it, wipe the current listing clean (CTRL+X), switch over to winword.exe click the link.. back to process explorer and stop tracking (CTRL+E), explore.. ;P you might also want to upload the LOG by saving it with CTRL+S so i can also have a look at it

    Also might want to look at the Registry first and see if something did not get set correctly. (You can also just Export the 2 keys and upload or copy/paste into a codebox here
    Code:
    HKEY_CURRENT_USER\Software\Classes\http
    HKEY_CURRENT_USER\Software\Classes\https
    HKLM\Software\Microsoft\Windows\Shell\RegisteredApplications\UrlAssociations\http\OpenWithProgids (might not exist, if it does delete)
    That's obviously no given solution, but trying to find why/what its causing it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    I have to say this is very strange. I must say this doesn't affect Office 2010 at all because I have IE 10 disabled and all is well. I guess errors and workarounds like this happens when software like Office 2013 and Windows 8 are rushed to RTM status when there are plenty of "beta style" bug in them.
     
  8. MrG

    MrG MDL Addicted

    May 31, 2010
    839
    188
    30
    My problem first showed-up in O2010 in W7.
    After a clean install of W7 one of my favorite websites needed Adobe Flash installed for the "live cams", so I installed it.

    No choice to not install the Chrome TB or Chrome browser! so they both got installed after which I promptly uninstalled them in W7 CP/ uninstall programs.
    That's when my Word> hyperlink problem started. I googled & found several people saying the only way to fix it was installing Google Chrome again!!! lol

    I kept drilling down & found the MS Support page & used the Fix-it there & that cured the problem.
     
  9. M0rriss0n

    M0rriss0n MDL Senior Member

    Sep 17, 2011
    318
    96
    10
    #10 M0rriss0n, May 24, 2014
    Last edited by a moderator: Apr 20, 2017
    (OP)
    This week did a clean install of Windows 8 with Office 2013 and disabled IE because I use Pale Moon.
    Opening a link in Outlook 2013 give me the nag screen once again,
    " Your organization's policies are preventing us to complete this action for you."
    The solution however is very simple, and no IE resetting is required!
    Open notepad and copy/past.

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command]
    @="\"C:\\Program Files (x86)\\Pale Moon\\palemoon.EXE\" -nohome"
    
    You can put every browser and his path in there!
    save as something.reg and execute.
    Hyperlinks work again in your favorite browser.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. s1ave77

    s1ave77 MDL Guide Dog/Dev

    Aug 15, 2012
    15,151
    20,582
    340
    #11 s1ave77, May 24, 2014
    Last edited by a moderator: Apr 20, 2017
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command]
    @="\"C:\\Program Files (x86)\\Pale Moon\\palemoon.EXE\" -nohome"
    Please post code in a Code box. After 50 chars the forums soft inserts a break that will screw the posted code ... check yours, in the reg path after \shell :cool2:.


    *************************
    EDIT:

    HINT: The Code Box can be created via the '#' button in post editor :smartass:.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. M0rriss0n

    M0rriss0n MDL Senior Member

    Sep 17, 2011
    318
    96
    10
    Found it already, but thanks for the tutorial.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...