Unable to upgrade to 8.1, Microsoft test is faulty.

Discussion in 'Windows 8' started by catimimi, Oct 18, 2013.

  1. catimimi

    catimimi MDL Novice

    Nov 21, 2007
    17
    0
    0
    HI,

    I've a desktop with windows 8 installed and activated by microsoft.
    While I attempt tu upgrade from windowsstore, I'm told that my processor is not compatible, that I need PAE, SSD2 and NX.
    If I run the upgrade assistant, I've the same result.

    If I run coreinfo, I find that PAE, SSD2 and NX are supported, which is correct since I was able to install windows 8.

    The test made by microsoft seems faulty. What can I do ? Where can I report for this problem ?

    Regards.
    Michel.
     
  2. ian82

    ian82 MDL Expert

    Mar 7, 2012
    1,147
    302
    60
    upgrade that old dinosaur you have or stick to Windows 7
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. kornykova

    kornykova MDL Novice

    Jun 20, 2010
    2
    0
    0
    I get exactly the same problem!

    Went to upgrade to 8.1 today (I have Windows 8 Pro with Media Centre) and the Upgrade Assistant said I couldn't as my processor (Pentium D 820 2.8GHz) doesn't support PrefetchW.
    I downloaded MS's CoreInfo tool and it says it DOES support PrefetchW (and PAE, NX, SSE2, LAHF, SAHF, CMPXCHG16B too!).
    So, according to CoreInfo my Pentium should support 8.1 but the Upgrade Assistant disagrees.
    I checked my BIOS too and "Execute Disable Memory Protection Technology" (Dell BIOS A05) IS enabled!

    Any thoughts on what I can do to get upgraded to 8.1?

    Thanks
     
  4. lolindirfab

    lolindirfab MDL Novice

    Aug 16, 2012
    30
    4
    0
    Mmm, this^ seriously, what processor do you have?
     
  5. catimimi

    catimimi MDL Novice

    Nov 21, 2007
    17
    0
    0
    What a valuable reply !

    It would have been more advisable to tell that the flags : CX16 PREFETCHW and LAHF-SAHF are necessary for windows 8.1 64bits and according to coreinfo my processor Pentium 840 extreme edition doesn't support some of these flags.

    Regards.
    Michel.