Unknown device in Amilo Pa2548

Discussion in 'Windows 7' started by gett, Oct 28, 2009.

  1. gett

    gett MDL Novice

    Oct 24, 2009
    16
    0
    0
    Hi

    I instaled win 7 ultimate in my Fujitsu-Siemens Amilo Pa2548 notebook. Everything works fine except this unknown device

    Untitled.jpg

    I have AMD Turion X2 64 processor, which is recognized by the system
    Any ideas, please
    :)
     
  2. secr9tos

    secr9tos MDL Addicted

    Jul 28, 2009
    999
    133
    30
    coprocessor sounds like nvidia chipset. Did you try to install the latest chipset-driver for your notebook?
     
  3. Akko

    Akko MDL Junior Member

    Aug 21, 2009
    74
    12
    0
    in my pi 2530 it was the irda driver
     
  4. m4dbra1n

    m4dbra1n MDL Novice

    Oct 10, 2009
    3
    2
    0
    Try this

    Hi gett,

    I have the same nb as you and time ago I was in the same situation.

    While looking everywhere for some drivers, I've found that the driver for Vista from the FJS site works.

    So do the following:

    - Go to the support page of FJS: h++p://support.ts.fujitsu.com/COM/support/downloads.html (replace ++ with tt)

    - Select your notebook model, PA2548

    - Select Vista

    - In Chipset section, download the second package, the "nVIDIA nForce System Management Controller" version 5.1.2600.131

    At this point you can do 2 things: install it with the setup in administrator mode or point to the SMU folder contained in the zip manually

    As far as I remember this worked for me, hope it works to you ;)

    Let me know!

    Bye!
     
  5. gett

    gett MDL Novice

    Oct 24, 2009
    16
    0
    0
    Thanx toa all for answers!

    Problem was trivial: I instaled 64 bit wersion of win7. After installing 32 bit version, all drivers downloaded from fujitsu site works! :)

    Good luck to all!
     
  6. Tolmach

    Tolmach MDL Novice

    Mar 18, 2010
    1
    0
    0
    Hi! So you have just downloaded VISTA drivers from official fujitsu-siemens site and they worked for Win 7 (x86)?