Updated 12.05.2011 Version clock keeps resetting

Discussion in 'Windows 7' started by bluerose5, May 30, 2016.

  1. bluerose5

    bluerose5 MDL Novice

    May 27, 2016
    37
    3
    0
    Recently installed version "Updated 12.05.2011 Windows 7", and noticed that despite the time zone being in the correct setting (Pacific Standard time), that the Clock Was off by several hours. I searched online for answers and read somewhere that deselecting the 'sync with internet clock' might help the issue. It did seem to resolve the issue for the short-term, but after some updates I have noticed once again that my system clock is 7 hours ahead.

    Is there some known bug with this install for this time setting? How might I resolve this issue?
     
  2. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,448
    278
    60
    I seem to recall "recent" time zone updates. Have you run WU or otherwise updated?
     
  3. catsado

    catsado MDL Novice

    Dec 23, 2010
    13
    0
    0
    Maybe your BIOS battery need exchange.
     
  4. ypvs

    ypvs MDL Novice

    Dec 21, 2013
    38
    2
    0
    In the date/Time Control panel section the third tab is Internet Time, Try another syncing site eg time.windows.com
     
  5. bluerose5

    bluerose5 MDL Novice

    May 27, 2016
    37
    3
    0

    it seems to be resetting with all the different internet clocks, and when internet sync is off.

    why is this happening?
     
  6. bluerose5

    bluerose5 MDL Novice

    May 27, 2016
    37
    3
    0
    yes may updates.
     
  7. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,448
    278
    60
    Time for a new battery like catsado suggested.
     
  8. bluerose5

    bluerose5 MDL Novice

    May 27, 2016
    37
    3
    0
    #8 bluerose5, May 31, 2016
    Last edited: May 31, 2016
    (OP)

    my battery is brand new, so that not the issue .
     
  9. bluerose5

    bluerose5 MDL Novice

    May 27, 2016
    37
    3
    0
    What brought it to my attention was that my f.Lux wasn't turning on, so I went and checked the time in BIOS and noticed that it was forward by 7 hours. This explains a few things but it doesnt stop there.. I should mention at this point that I am doing booted, with a Windows7 partition and an Ubuntu 14.04 partition.

    If I go into BIOS and set the time to the correct time, and load into Windows everything stays fine. I can restart the system into Windows and nothing changes. As soon as I log into Ubuntu via the Windows bootloader something changes. If i reboot after logging into Ubuntu and go into BIOS, the clock is off again (forward 7 hours each time)
     
  10. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,448
    278
    60
    I get that. But many a computer part has been bought "brand new" only not to work as expected or not at all. When all else fails, replace the battery and see what happens. Or at least pull it out for 10 seconds so things reset. Sometimes there is a jumper you can use to "jumper it out" so to speak.
     
  11. Myrrh

    Myrrh MDL Expert

    Nov 26, 2008
    1,387
    491
    60
    Ubuntu is configured to wrong time zone and is updating CMOS clock.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. bluerose5

    bluerose5 MDL Novice

    May 27, 2016
    37
    3
    0
    #12 bluerose5, May 31, 2016
    Last edited: May 31, 2016
    (OP)
    I'm open to the possibility that this is so.. this happened thbough after i installed windows, and the windows bootloader
     
  13. frepsz

    frepsz MDL Junior Member

    Aug 26, 2014
    71
    18
    0
    Ubuntu loves to set UTC time into the hardware clock. While it doesn't hurt normal usage, it hurts dual booting.

    Boot Ubuntu, open a terminal, then type "hwclock --systohc --localtime". After this, it will store local time, just like windows, and your clock won't be messed up anymore.
     
  14. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,218
    1,810
    90
    #15 Carlos Detweiller, Jun 3, 2016
    Last edited by a moderator: Apr 20, 2017
    There's also a Registry setting for Windows to assume BIOS time is UTC:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
    "RealTimeIsUniversal"=dword:00000001
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...