USB not working in Windows 8

Discussion in 'Windows 8' started by ananrulz, Sep 9, 2012.

  1. ananrulz

    ananrulz MDL Novice

    Nov 8, 2011
    4
    0
    0
    My all 5 USB ports are not working in windows 8, i had confirmed it through linux mint live disc that it isnt a hardware error,

    in devmgmt it shows 'Error Code 43', i had tried uninstalling that and restarting but that also works for a few seconds, and then again same error comes again,
    I cant even do any thing or connect any device through USB.

    PLZ show me a solution.
     
  2. kl1k

    kl1k MDL Novice

    Aug 7, 2009
    15
    1
    0
    USB works perfectly well. What motherboard do you have? Have you checked under device manager that all the drivers are installed.
     
  3. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,749
    1,959
    210
    First: Update the BIOS of your Motherboard to the latest version! Than check your USB Ports again.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. suitsyou

    suitsyou MDL Novice

    Aug 30, 2012
    10
    2
    0
    Or look for the latest Chipset set drivers for your motherboard make and model from the manufacturer.
     
  5. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    7,008
    7,161
    240
    if BIOS shows USB ports active, you are fine. The only thing, you must do, is to install all machine related original drivers. Chipset is the most important one. If W8 only has a standard version, you need to take the manufacturer's one and then you go
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,749
    1,959
    210
    That's not allways true. For example, on an Asus MB I had to update the BIOS because of the same problem with Windows 8 Pro. In Windows 7 USB just worked fine but Windows 8! Just updated the BIOS and all were OK!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    7,008
    7,161
    240
    I agree with you but wanted to point out, that you must have your USB ports switched to active first in the BIOS. Then you can find out ways to make them work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,749
    1,959
    210
    Personally I never used the default settings of the BIOS, always checked and adjusted before the first use of the computer. That includes the USB settings as well as Memory Settings and to enable AHCI because I use to work with Hot-Plug and external eSata HDD's.

    Just for to test the USB of the MB is working properly, you could use an bootable USB stick and use the BIOS Boot Manager for to boot from those Stick. In that regard, I allways use to install Windows OS since Vista from USB only.

    If the USB didn't work from within Windows 8 after done that, that clearly means there's a Driver problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    I use Asus elusively now, and I have never messed with BIOS to get USB to work. I updates Bios once on my ASUS X52JT to eliminate a noise that one function combo was creating while playing music that was it. Lets mention that BIOS flashing is a risky operation if not done properly, it is best to do it outside of windows OS.

    Pisthai, what could I change in BIOS to benefit from besides the AHCI you mentionned?
     
  10. MrG

    MrG MDL Addicted

    May 31, 2010
    828
    182
    30
    I also use ASUS MB's exclusively for my desktop rigs.

    I usually install the chipset drivers for LAN & USB 3.0 but w/ win8 I didn't have to as the drivers were included & all are working fine.
    The USB 3.0 native drivers in Win8 combined w/ the OS actually give a faster Read/Write speed than in Win7 using the ASUS chipset CD drivers!
     
  11. buksnatata

    buksnatata MDL Member

    Oct 22, 2011
    212
    92
    10
    Try to go to control panel, system and security, power options, change plan settings, change advanced power settings then usb settings and disable usb selective suspend settings.
     
  12. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,749
    1,959
    210
    Sorry for the late reply, see where am I (GMT +7h)!

    Ok, regarding your question:
    • check the Memory settings, adjust if needed
    • check CPU settings
    • if unlock CPU is available chose that but do not start overclocking at first!, that you could do later while testing
    • same applies for Memory Speed, Voltage
    • disable Floppy if you didn't have one inserted

    There some MB's like MSI Boards which most of the time need the adjustments in first line for the installed memory which could also have an effect on the CPU speed. Just set the settinbgs of the Memory and CPU as they should and do not overclock in first run. After everything works fine, you could start overclocking if that's what you like to do. Keep in mind that an important factor is the Temperature of CPU, MB and Memory Modules and adjust the settings step by step in tiny steps.

    If you didn't have an Floppy Drive in your computer, disable the floppy completely within the BIOS. I use Drive A and B for my Data HDD's, one fixed in the computer as drive B and one removeable using AHCI/Hot Plug as Drive A. On my Laptop I use Drive A for the external HDD connected via USB. Doing so, all times I've the most important Data Drive on the same Drive letter and the installed apps which may need those data connecting automatic to that drive. Ease the system a bit and I didn't have to think where the hell the data are, on which drive?!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. MrG

    MrG MDL Addicted

    May 31, 2010
    828
    182
    30
    Nope, I prefer the Intel drivers on my board.
     
  14. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    Thanks my fellow MDL man, I appreciate and will look into it


     
  15. Arbus33

    Arbus33 MDL Novice

    Nov 4, 2012
    1
    1
    0
    [SOLVED] Thanks

    I had the very same problem with USB and this tip solved it :). Many thanks.