Usb ports problem

Discussion in 'Windows 7' started by anima, Mar 27, 2012.

  1. anima

    anima MDL Junior Member

    Feb 17, 2011
    62
    2
    0
    Hallo everyone

    lately i am facing a weird problem,my mouse all of a sudden just does not respond.Sometimes that lasts for a couple of seconds some other it needs reboot or to change a usb port.My mouse was working fine and that started 2 weeks ago without doing anything at all(no new installs or hardware change).I even formated my pc but the problem remains.

    I noticed that when this happens and i change the usb port i might have to try 3-4 usb ports to make it work....or it may not work at all and i have to reboot.

    Any ideas why this happens or how can i check what is wrong?
     
  2. sid_16

    sid_16 MDL Giveaway Organiser

    Oct 15, 2011
    2,309
    4,329
    90
    I'm not an expert but I'd seen similar problem with my friend's computer, after checking thoroughly the motherboard found dead . You know what was the solution.:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,447
    277
    60
    Do other USB devices have the same problem? If yes then suspect the ports are bad; if no then suspect the mouse is bad.

    "Bad" USB ports can be either a hardware problem or a software problem. One thing you can do to try and fix the problem is to uninstall all USB devices (under "Universal Serial Bus controllers") from within the Computer Management console. Windows will re-install them all upon rebooting. If that doesn't fix your problem you're back to a bad mouse or bad main board.
     
  4. anima

    anima MDL Junior Member

    Feb 17, 2011
    62
    2
    0
    #4 anima, Mar 27, 2012
    Last edited: Mar 27, 2012
    (OP)
    well the mobo is a year old...every other device connected to usb port is working fine....tested the mouse to another oc and it works fine....

    i should also mention that when it stops working the light in the base of the mouse is on,so it has power..

    is there a way to know if the usb ports are dying?

    PS. I will now try to uninstall all USB devices from within the Computer Management console.

    Edited:Well so far so good .....i will wait and see tomorrow too.
     
  5. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,447
    277
    60
    #5 PhaseDoubt, Mar 28, 2012
    Last edited: Mar 28, 2012
    Windows 7 also had an issue with the USB ports that was described on this forum. I remember little about it but the fix was also given here and that fix involved uninstalling or repairing certain USB instances in Computer Management. MS later issued an update that was supposed to fix the issue. Memory is foggy on this but a search of this forum relative to Windows 7 USB problems will lead you to it eventually.
     
  6. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,760
    3,118
    300
  7. anima

    anima MDL Junior Member

    Feb 17, 2011
    62
    2
    0
    thanks for the additional help but for now i am not trying it since the solution PhaseDoubt suggested(to uninstall all USB devices) seems to be working for now...if the problem persists i will check it
     
  8. sid_16

    sid_16 MDL Giveaway Organiser

    Oct 15, 2011
    2,309
    4,329
    90
    Thanks, Mr/Ms Anima , thanking me for that unuseful post (of mine).:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...