VGA monitor turning off after disconnecting HDMI

Discussion in 'PC Hardware' started by Stannieman, Jan 25, 2015.

  1. Stannieman

    Stannieman MDL Guru

    Sep 4, 2009
    2,232
    1,803
    90
    #1 Stannieman, Jan 25, 2015
    Last edited: Jan 26, 2015
    Hi all

    I have kind of a weird problem.
    The pc at our youth café has it's primary (vga) monitor connected to the vga out of the pc. On the hdmi-out is a lenovo hdmi to vga converter, the vga out goes through a vga switch so it can be connected to either a beamer or a tv.

    The converter is one like this: x17725401711_0B47069_20120627115555.gif.pagespeed.ic.J7NFL0TaSb.png

    The problem is that if all displays are on and then the one on the converter is turned off, the primary display also goes black. Then when the beamer/tv is turned on again the monitor gets signal again. Also when the hdmi is plugged in but the tv/beamer is turned off, the pc won't post (forgot what the exact beep code was).
    The tv/beamer model number and supported resolutions are correctly detected through the converter.

    The pc is a medion pc running win8.1 and the display adapter is an intel 4600 with the latest drivers, mainboard is MS-7848.
    Any ideas on this? Is it maybe enforced by the hdmi standard somehow?

    Tomorrow I'll post what the exact beepcode is.

    Thanks
    Stan

    UPDATE: Sometimes it doesn't give beepcodes (like today). When it doesn't and tv/beamer is disconnected then it does give image when booting, (LOGO + circling dots), but then the screen goes blank until the tv/beamer goes on. When the hdmi converter is unplugged from the pc altogether then the vga display keeps working.
    I double checked and the primary monitor is definitely set as primary.

    So what basically happens is that when the converter is in the hdmi socket but nothing is on the other side of it, either the driver or windows says: "No no man! I won't send any signal to vga either!".
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...