visual c++ error updating languages

Discussion in 'Windows 7' started by masterbyte, Jul 26, 2009.

  1. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    i have downloaded the language packs, but when i try to locate the language pack on my hard disk i recieve this error:

    how can i fix this error?
     
  2. VelleX

    VelleX MDL Member

    Jul 14, 2009
    203
    26
    10
    I think you cant fix it.

    This error comes when u used a old LP, e.g. the 7264, and edited the update.mum.

    Maybe you could try uninstalling the LP
     
  3. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    i have tried also uninstall the language pack and i recieve the same fuc*ing error... :mad:
     
  4. Shadoko

    Shadoko MDL Novice

    Jul 14, 2009
    13
    0
    0
    I had to do an Upgrade-Install from a proper dvd.
     
  5. VelleX

    VelleX MDL Member

    Jul 14, 2009
    203
    26
    10
    Do you get the same from command line?

    lpksetup /u
     
  6. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    yes... :confused:
     
  7. VelleX

    VelleX MDL Member

    Jul 14, 2009
    203
    26
    10
    what is when you use "DISM /online /Add-Package /PackagePath:x:\" to try to add the LP?
     
  8. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    i used the program "dependency walker" to diagnose the lpksetup and i have errors with this files

    IESHIMS.DLL
    SHLWAPI.DLL
    IEFRAME.DLL

    they all related with internet explorer.
     
  9. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    is installing the lp right now. later i will repor if resolve my problems.
     
  10. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    VelleX i can install the lp with your method but if i use the "lpksetup" i get the same error.
     
  11. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    my version has 2 languages:
    english and portuguese

    the portuguese it was version 7264 slipsteamed into instalation dvd.
    i switched to english and i do "DISM /online /Add-Package /PackagePath:" to install (reinstall) portuguese language pack. and i can install the language pack whith this trick.

    but with official language pack installed i get the same error... grrrrrrr :mad:
     
  12. Lenmaer

    Lenmaer MDL Addicted

    Jul 3, 2009
    579
    3
    30
    You're good for a clean install, sorry.
     
  13. VelleX

    VelleX MDL Member

    Jul 14, 2009
    203
    26
    10
    maybe you could first try to remove the old languagepack with DISM and then add the other LP again.
     
  14. SongRemainsTheSame

    SongRemainsTheSame MDL Novice

    Jul 20, 2009
    28
    0
    0
    #15 SongRemainsTheSame, Jul 27, 2009
    Last edited: Jul 27, 2009
    Thanks for your answer, but How could i do that ?

    "Tant pis", nevermind, i'm on for a reinstalling party... :(
    It was just an excellent occasion to learn more about dism.exe.
    I've red some articles but all are about slipstreaming, i didn't know that it could modify an existent installation...
     
  15. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    i can add all the language packs i want with "dism" command withou errors.
    what is the command line to remove a language pack?
     
  16. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    ok i found how to remove a language pack

    i have pt-pt and installed for testing pt-br
    this is how i remove the lp

    i will try remove all lp and reinstall only that i want and see if the bug exists..
     
  17. masterbyte

    masterbyte MDL Novice

    Mar 18, 2008
    36
    0
    0
    i removed the pt-pt language from 7264 copyng the rtm lp to my hard disk and using the same command

    i restarted and running the "lpksetup" the c++ bug is gone!!!!
    i can now install lp the normal way

    thank you all for the help!