VMware and Hyper-V not compatible

Discussion in 'Virtualization' started by EFA11, Mar 23, 2013.

  1. EFA11

    EFA11 Avatar Guru

    Oct 7, 2010
    8,796
    6,746
    270
    #1 EFA11, Mar 23, 2013
    Last edited by a moderator: Apr 20, 2017
    I don't know how many of you use both Hyper-V and VMware, but if you have Hyper-V installed, I am sure you noticed that VMware will not run as long as Hyper-V has a role on the computer. After some searching here, I see that "hypervisorlaunchtype" has only been discussed with Windows Loader setting it to Auto.

    I would need to get some input from DAZ on what this will do to the Loader if anything?

    Anyway, with this it is the opposite, the hyper-v role needs to be off for VMware to work. As you cannot really uninstall Hyper-V once it is installed, you can disable it, and in my opinion is basicly the same as removing it from the system. Since I use VMware more often than Hyper-V, I chose to disable Hyper-V until I have a need for it again.

    The fastest way, possibly the only way that I have found was to, open Hyper-V manager and "stop service" on the right panel, and then at an elevated command prompt I entered what you see below.
    Code:
    Disable Hyper-v at an elevated command prompt, and reboot.
    
    
    bcdedit /set hypervisorlaunchtype off
    
    Code:
    To enable Hyper-v to use Hyper-V again, at an elevated command prompt, and reboot
    
    bcdedit /set hypervisorlaunchtype auto
    
    Once you set to off, it should give you a confirmation that the setting was applied. After a reboot and the system configures itself, VMWare is functional again.

    I thought this might be helpful to someone needing to run VMware after Hyper-V has been installed on Windows 8 Pro. At least until something easier or simpler (if possible) can be done. :hypo:
     
  2. rrohela

    rrohela MDL Expert

    Sep 1, 2009
    1,612
    1,405
    60
    No other solution possible... If you want to play with both at same time just used Nested setup, Hyper-v inside VM on workstation...
     
  3. Leica

    Leica MDL Member

    Nov 15, 2012
    120
    10
    10
    Hyper-V will not run under VMWare! Even if VT-x is enabled it will still refuse to run as it recognises that it is a virtual machine and says 'no'.
     
  4. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,215
    14,777
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Leica

    Leica MDL Member

    Nov 15, 2012
    120
    10
    10
    #6 Leica, Apr 2, 2013
    Last edited: Apr 5, 2013
    Well I tried it a while ago on a Mac with the latest Fusion 5.0.3. And yes I have a Core i5 so VT-x is no problem. I couldn't get Hyper-V to run. ESXi ran fine.

    Oh well, sorry for the mis-information. :eek:

    UPDATE: Hyper-V will not work in VMWare products even with VT-x redirection enabled. HOWEVER if one tweaks the configuration file in ESXi or chooses "Hyper-V" as the operating system (in Workstation and Fusion), then it works fine!

    What I was doing was using the guest operating system as "Windows Server 2012" (because it was so!). Having changed it to "Hyper-V", now it works :)