VMware BIOS and try to apply to my Vmware Fusion 5

Discussion in 'Virtualization' started by jiemin, Jul 3, 2013.

  1. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    I just download the VMware BIOS and try to apply to my Vmware Fusion 5, but it seems not working.

    My scenario is like this:

    1. Migrating OEM windows XP (which is on Toshiba TECRA M10 laptop) to Mac OS Mountain Lion
    2. It prompts to reactivate windows XP in Vmware

    So which BIOS file should I use for bios440.filename description? As I notice there are two folders in Toshiba folder, with 2.0 and 2.1. In each folder there are lots of .rom file

    Much appreciate you can give me the guide or info.

    Regards
    Jiemin
     
  2. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,834
    1,748
    180
    2.0/2.1 relate to SLIC (of no interest to XP as it uses SLP 1.0)

    Use any SLP 1.0 one & oembios changer (from XP section) to change oembios.* set
     
  3. bigfoot15

    bigfoot15 MDL Member

    Jul 22, 2009
    102
    218
    10
    Any bios from the mega pack should work for xp. They all contain slp 1.0 in them.
     
  4. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    Thanks, I am trying to set bios440.filename="361H_toshiba_a0081_21.rom" and copy the .rom file into the same vmware folder. Unfortunately it seems not working.

    Any ideal? Thanks
     
  5. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    Thanks, big foot.

    I am trying to set bios440.filename="361H_toshiba_a0081_21.rom" and copy the .rom file into the same vmware folder. Unfortunately it seems not working. Any ideal?
     
  6. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,389
    15,072
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    sorry bro I'm on Mac OS, it is not working for me
     
  8. bigfoot15

    bigfoot15 MDL Member

    Jul 22, 2009
    102
    218
    10
  9. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    BigFoot15,

    Noted, just want to clarify on point 2.

    Due to my VMware fusion running on Apple Mac OS, I don't think it can run the link you shared. Can I run it on my original PC, which is Toshiba TECRA M10. Kindly advise.

    Much appreciate :)
     
  10. bigfoot15

    bigfoot15 MDL Member

    Jul 22, 2009
    102
    218
    10
    Isnt your vm xp? It will certainly run on xp.
     
  11. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    Yes, Sir. Kindly find attached screenshot :) SLP1.0.JPG
     
  12. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,389
    15,072
    340
    Is SLIC Toolkit running inside your VM?? Then you already have necessary SLP strings.

    :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    Yes, this is running at my old Toshiba laptop, not the virtual machine on my Mac OS.

    Why the virtual machine on Mac OS keep asking me to re-activate the windows XP license?
     
  14. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    Also I find something in advanced tab, not sure whether it is correct or not. advanced.JPG
     
  15. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,275
    1,865
    90
    Because that VM software you use does not have the SLP strings in its BIOS/DMI?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    But I have downloaded the "Vmware bios mega pack 361H.7z" and extracted Toshiba .rom file into my Mac OS vm folder.

    Also biso440filename="xxxx.rom" is added into vm configuration file.

    Appreciate you elaborate it ? :)

    Regards
    Jiemin
     
  17. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,389
    15,072
    340
    Run SLIC Toolkit or this inside the VM to detect SLP string & post result.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    My Windows XP vm is running in Apple Mac OS, I'm afraid I can not run SLIC Toolkit on my Mac OS.

    Any ideal ?
    :eek:

    Thanks
     
  19. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,275
    1,865
    90
    Run it inside the XP VM.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. jiemin

    jiemin MDL Novice

    Jul 3, 2013
    33
    3
    0
    Dear all, maybe let me describe my scenario again that everyone have the full page :)

    1. I have one old Toshiba TERCA M10 latop, which is running OEM windows XP
    2. I bought one Apple Macbook with apple OS X mountain lion inside
    3. I installed the vmware fusion on my Apple Macbook
    4. With vmware migration tool, I export my Toshiba windows into Macbook vmware fusion
    5. Virtual machine Windows XP on Macbook keep asking me to reactivate the Windows during it bootup
    6. I have put the Toshiba .rom into the vmware fusion folder and added the bios440filename=xxxx.rom into the configuration file
    7. Still VM windows XP keeps asking to reactivate the Windows

    Please advise how can I proceed, my VM is running on my Apple Mac OS!

    Regards
    Jiemin