w2012 R2 essentials and whs2011 on same network: how to connect to both ?

Discussion in 'Windows Server' started by doudoufr, Apr 8, 2015.

  1. doudoufr

    doudoufr MDL Novice

    Feb 3, 2015
    hi here !

    So i have two servers
    1 w2012 r2 essentials with an address like xxx.remotewebaccess.com
    1 whs2011 with and address like xxx.homeserver.com

    What's working for now :
    * remote web access : i change the port for one (whs2011, using 4430) i connect by entering xxx.homesever.com:4430/remote for one, and xxx.remotewebaccess.com/remote for the other (ports are open on my router and redirect to the specific IP)
    * remote desktop : i open the port on my router (3389 and 3399). sor for one i use xxx.remotewebaccess.com:3389 and for the other xxx.homeserver.com:3399).

    Now what's not working

    As I understand, for the vpn, (sstp) it use the port 443.
    So I can connect to my w2012 server using the vpn (because it use the port 443), but for my other server (whs2011) ?
    I cant open another 443 port on my router. (already in use by the w2012).

    On my client pc, i try to enter the address xxx.homeserver.com:4430, but it doesn't work. and if i don't specify the port number, it connect to my 2012 server.
    Also I red that the client connect automatically with port 443 (and there is no way to change that).
    I also noticed that there is a registry key to modify, to change the vpn port. (listener port). i've changed that to 4430 too, but it doesn't work.

    When I try to connect with the vpn it says "error 720 : a connection to the computer could not be establish..."

    So i don't know what to do....I'm stuck.
    If you have any suggestions.....

    ps : sorry for my english, i'm french.
  2. doudoufr

    doudoufr MDL Novice

    Feb 3, 2015
    #3 doudoufr, Apr 8, 2015
    Last edited: Apr 8, 2015
    Well, in the meantime i do some research and change things and it works now !
    i just specify IP address in the configuration of the routing and remote config (on the server) (192.168.2.XX, differnt from my local network) and now, it works !

    But (there is always a but), when i'm connected with the vpn, i loose internet :weep:. (which is not the case, when i'm connected with the 2012vpn).

    [edit] : I found the solution, in the properties of the vpn connection (on the client) you have to untick the box "use the defaut gateaway for the remote network".

    So it's all good :)