W2K8 R2 and Exchange 2007

Discussion in 'Windows Server' started by Dr.Kimble, Aug 22, 2009.

  1. Dr.Kimble

    Dr.Kimble MDL Novice

    Jul 17, 2009
    27
    0
    0
    #1 Dr.Kimble, Aug 22, 2009
    Last edited: Aug 22, 2009
    The good news was, that now the localized versions of R2 are available at MSDN. So we had the idea to upgrade one of our servers

    Unfortunately Exchange 2007 (SP1 incl. Rollup 9) is running on this machine. So we get an error while upgrading, because it seems that Exchange 2007 is only supported with SP2 (which might be available in a few weeks or month) under R2.

    Anyone with the same problem (or even a solution) ?
     
  2. irishj

    irishj MDL Novice

    Jan 13, 2008
    7
    0
    0
    I had the exact same problem. I think the client access role was were i had the error.

    No workaround i could find, as you said, even with rollup 9, it wouldn't install. Had to go back to Win2K8.
     
  3. irishj

    irishj MDL Novice

    Jan 13, 2008
    7
    0
    0
    I actually just searched a little there and found some info on the subject / issue.

    "If you get the error "Access Denied" and an error number of "3221684229", if you right-click on the setup.exe file and cloose the run it in compatibility mode (I chose Vista SP1) then the mailbox role successfully installs"

    When asked if Exchange SP2 would resolve these issues, a Microsoft MVP has replied...

    "Exchange 2007 SP2 will be blocked to install on Windows 2008 R2, setup will NOT allow you to install it on R2, further info will be available when it will release..."

    So..don't wait for SP2, install now with the tip above and hopefully it works. Some guy confirmed it worked for him...might try it tomorrow evening.
     
  4. Dr.Kimble

    Dr.Kimble MDL Novice

    Jul 17, 2009
    27
    0
    0
  5. crus

    crus MDL Novice

    Feb 17, 2009
    16
    0
    0
    Hi all,

    does anybody know here when the new version WSUS 3.0 SP2 will be released?

    I do also have an W2K8 R2 installation and I want not to go back again ;-D
    Because i think that i can not update from W2K8 to W2K8 R2 in an easy way without any difficulties.


    Best regards,
    Crus
     
  6. Dr.Kimble

    Dr.Kimble MDL Novice

    Jul 17, 2009
    27
    0
    0
    Afaik in the next few weeks, same as Exchange SP2
     
  7. crus

    crus MDL Novice

    Feb 17, 2009
    16
    0
    0
    Hello Guys,

    currently I am trying to install an Exchange Server 2007 SP1 on a Windows Server 2008 R2. But it seems that there is no chance to install it.
    I have also tried to use the trick with the compatibility mode but it does still not work...

    Error:
    An error occurred. The error code was 2147504141. The mesage was The property cannot be found in the cache.


    I get this error on the "Hub Transport Protocol" and "Mailbox Role".


    So i think we really have to wait for SP2?
    Or do you have any other ideas maybe?


    Best regards,
    Crus
     
  8. Dr.Kimble

    Dr.Kimble MDL Novice

    Jul 17, 2009
    27
    0
    0
    This trick can't work, forget ist

    At least or even for 2010

    The only "workaround" is to install 2K8R2 and to put Exchange 2007 in a HyperV with 2K8
     
  9. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    55
    60
    DO NOT INSTALL EXCHANGE 2k7 on Wk28R2. IT WILL BREAK IT.

    Why can't you install Exhcange 2k7 on R2? Mainly because powershell between the 2 OSes is greatly different. So don't try to install it, just use Windows Server 2008 or Windows 2003 Server x64 edition.

    If you need an Exchange Environment that will run on Windows Server 2008 R2 use 2010. The RC is out now and the final will be out soon. However direct upgrades are not supported so you will still need to stand up a new box to migrate from 2007 to 2010. Also 2010 beta to RC upgrades are not possible.
     
  10. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    55
    60
    it's not recommended yes it might work, but there are still a lot of things broke because of the fundamental powershell changes.

    WSUS SP2 has been in beta since May. WSUS SP1 worked fine until the RC then they hard blocked it.