W8 in Vmware Workstation Tech Prev 2012

Discussion in 'Windows 8' started by sebus, Jun 19, 2012.

  1. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,879
    1,773
    180
    I must have missed something and somebody might know what

    Eventually needed to try Windows8-ReleasePreview-64bit-English in VMware Workstation Technology Preview 2012 (nothing moded for this exercise, just in case)

    Using default settings (hardware compatibility Workstation 2012, Windows 8 64-bit) it installs fine from iso, but never boots after that (stays on the Windows black logo)

    Changing the hardware compatibility to Workstation 8 makes it work OK (but I can never login to it, it just spins around)

    Then renaming vmware-vmx.exe to vmware-vmx-debug.exe (so I do not get the debug warning) I am back to the same as originally, it does not load & stays on the Windows black logo

    Anybody having any idea?

    sebus
     
  2. roirraW "edor" ehT

    roirraW "edor" ehT MDL Addicted

    Sep 1, 2007
    616
    213
    30
    The latest version of VMWare Workstation 8.0 (actually my old build of 8.0, too) runs Windows 8 RP just fine for me (installed selected Windows 7 x64). I abandoned trying the Tech Preview of VMware since the latest build of 8.0 actually has a much higher build number than the Tech Preview. So although some things haven't been implemented in 8.0 that have in 2012 (the ability to select Windows 8 from the list of OSes, don't specifically know what else), I'll keep using 8.0 at least until another preview is released, or the RTM of 2012. I *thought* that I did have Windows 8 running just fine in 2012, though.

    BTW, when you changed hardware compatiblity from 2012 to 8.0, did you reinstall/recreate Windows 8 after, or did you just see what the installation would do after you changed hardware compatibility? If you didn't reinstall Windows 8 after, you might want to try that if you really don't want to "downgrade" to 8.0.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. smartboyhw

    smartboyhw MDL Language Packs Specialist

    Feb 22, 2012
    332
    266
    10
    Add the following three lines to your .vmx file.mce.enable = "TRUE" cpuid.hypervisor.v0 = "FALSE" vmGenCounter.enable = "FALSE" Try that and it should boot. (Thanks to VMware communities).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. smartboyhw

    smartboyhw MDL Language Packs Specialist

    Feb 22, 2012
    332
    266
    10
    BTW, the June version fixed this bug. No more worries.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...