Weird problem, dism /cleanup-image causing system corruption.

Discussion in 'Windows 7' started by Anakunda, Jan 21, 2011.

  1. Anakunda

    Anakunda MDL Senior Member

    Feb 6, 2010
    269
    9
    10
    #1 Anakunda, Jan 21, 2011
    Last edited: Jan 21, 2011
    Hello, having tried SP1 cleanup method to free some space, got into various trouble after restart.
    1stly the logon screen takes ~ 15minutes to proceed, after getting to desktop, various problems appear, all dealing with external USB devices, some not recognized at all, others give notifications about not working at full speed, others newly detected and installed, some unsuccessfully...
    Looking to devmgr, I see several USB devices with status problem, mainly Standard extended host PCI to USB adapter (not working), In the detail it is versioned 6.1.7601.17514, but build date 21.6.2006(!!).
    Dunno how extensive are the damages but at least there's something wrong with USB drivers, can't fix other way than restoring disk to previous state.

    To proof dism is the culprit I have ran cleanup second time after successful sytem restore, with the exactly same result.

    I'd like to have more space and working drivers.
    Any explanation for this behavious?
     
  2. Squall-Leonhart

    Squall-Leonhart MDL Member

    Jul 23, 2009
    146
    33
    10
    your usb host controllers are likely using the SP0 version of the usbehci.sys file. Reinstall the ehci host controller prior to service pack cleanup to get the SP1 version installed.
     
  3. Kikoo

    Kikoo MDL Junior Member

    Jul 29, 2009
    80
    6
    0
    That's normal, Microsoft set it to that "build date" for compatibility with dumb Vista drivers from 3rd parties.