Wifi issues:connected but no internet

Discussion in 'Windows 8' started by udz368, Dec 16, 2012.

  1. udz368

    udz368 MDL Novice

    Nov 24, 2012
    5
    0
    0
    I just installed win 8 (already activated via wmc) i am having problems with my wifi (Realtek8187B) everytime i restart my laptop it is connected but no internet, but when i disable and then re-enable the wifi adapter it works i have internet connection. anyone else experiencing same issues?
     
  2. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    #2 anarchist9027, Dec 16, 2012
    Last edited by a moderator: Apr 20, 2017
    Do these two commands in CMD or Powershell

    Code:
    ipconfig -release
    #Then#
    ipconfig -renew
    
     
  3. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,644
    1,922
    210
    You'll need to have to set the Network connection for Wireless in Internet Protocol V.4 to Automatic for both IP and DNS addresses.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. udz368

    udz368 MDL Novice

    Nov 24, 2012
    5
    0
    0
    I tried both of your suggestions but didnt seem to work, my ip and dns address is set to default auto detect settings. there is a new windows update for my wifi driver ill give it a try hope it will work
     
  5. btokfans

    btokfans MDL Novice

    Oct 22, 2011
    11
    1
    0
    go to wireless network adapter property to disable power management setting then reboot.
     
  6. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    Or you can just go into Device Manager, uninstall your wireless card (DONT UNINSTALL THE DRIVERS), and then hit F5 to search for your wireless card again.
     
  7. S_A_S

    S_A_S MDL Member

    Oct 16, 2012
    236
    103
    10
    #7 S_A_S, Dec 19, 2012
    Last edited: Dec 19, 2012
    I think it's a USB 2.0 Wifi.

    Edit: Gonna send you a bill for use of my banner :tooth:
     
  8. udz368

    udz368 MDL Novice

    Nov 24, 2012
    5
    0
    0
    I installed the driver from microsoft and it worked, now i dont have to disable then re-enable my adapter settings every restart/boot, but when i use the diver from manufacturer i have to reconnect and disconnect.
     
  9. StarTac

    StarTac MDL Novice

    Nov 28, 2007
    12
    1
    0
    Same problem with the same wi-fi card Realtek.
     
  10. Botmaster

    Botmaster MDL Novice

    Dec 21, 2012
    5
    0
    0
    Reinstall drivers! :)
     
  11. TGNT

    TGNT MDL Junior Member

    Mar 2, 2010
    96
    3
    0
    I think the wifi card is bad. The temporary solution, just reset the wifi-router everytime you loose the connection to the pc.
     
  12. maddog0266

    maddog0266 MDL Expert

    Apr 26, 2011
    1,068
    117
    60
    D-Link wireless PCI card problem with Windows 8

    Has anyone had a problem with D-Links airplus xtreme G DWL-G520 PCI card.
    I have this card and never had a problem with Windows 7, but with Windows 8 once the card is install in the motherboard Windows 8 starts to load but then stops. If I go into safemode and disable the card the system boots fine and I can enable the card. The system works fine until I reboot, then the problem returns.

    Any help
     
  13. udz368

    udz368 MDL Novice

    Nov 24, 2012
    5
    0
    0
    Maybe or realtek driver doesnt support windows 8 at the moment,my wifi is working now no need to do reconnect/disconnect.i used the realtek driver that from microsoft