Win 11 Boot And Upgrade FiX KiT

Discussion in 'Windows 11' started by Enthousiast, Jun 28, 2021.

  1. Muggaen

    Muggaen MDL Senior Member

    Dec 30, 2011
    445
    187
    10
    I have downloaded the last update from uupDump multi arc iso x64 just droped the iso in Win_11_Boot_And_Upgrade_FiX_KiT_v2.0 Source_ISO w11 and hit Win_11_Boot_And_Upgrade_FiX_KiT_v2.0 cmd and just wait until finished all works out of the box when upgrade or clean install with no net on(offline) and got updates all the time until now so just do the install.
     
  2. uffbros

    uffbros MDL Senior Member

    Aug 9, 2010
    421
    55
    10
    @Muggaen ....Yep.....My problem was from me having a space in my .iso names. It works now.
     
  3. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,925
    68,169
    450
    I've tested it with every possible 22000.xxx ISO, from UUP, Techbench, MVS and converted from ESD, all worked fine. UUP dump 22000.194 ISO doesn't even need fixes like @IXMas showed before:)

    But at least you got it to work with one of the offered options:)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    5,000
    5,189
    180
    It should work, but it doesn't. Maybe VirtualBox is doing something fishy again. Need more tests.
     
  5. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,925
    68,169
    450
    I ran tests with vbox too, after reading someone saying it doesn't work, when i have finished creating all 22000.258 Business SVF(SFX) stuff i will test once more:)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    5,000
    5,189
    180
    Maybe the lack of Storage and/or RAM? Need to sleep first, then more tests.
     
  7. MIMMO61

    MIMMO61 MDL Senior Member

    Aug 19, 2009
    297
    75
    10
    Good morning.
    Congratulations on the tool.
    I performed the procedure n.2 when the installation start I must disconnect the internet, otherwise the message of hardware limitations appears.
    Do you always have to deactivate the Internet connection during installation?
    Thanks
     
  8. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,925
    68,169
    450
    Check post #2 of this thread, specifically the note.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. MIMMO61

    MIMMO61 MDL Senior Member

    Aug 19, 2009
    297
    75
    10
    Thank you.
    It's a problem being studied. However to avoid any notice for the moment it is better to install without the internet connection.
     
  10. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,925
    68,169
    450
    It's not a problem, just keep the system disconnected during upgrade setup, when the upgrade is started it should not be a problem being connected again.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. BAU

    BAU MDL Expert

    Feb 10, 2009
    1,301
    3,588
    60
    #571 BAU, Oct 20, 2021
    Last edited: Oct 20, 2021
    Unable to boot the release 11 media in VirtualBox despite having the bypass registry keys set is a known issue.
    Microsoft made lame changes to blacklist virtualbox virtualized devices. It is possibly hardware-dependent as well (i7-3770k on Z77 is blocked).
    It can still be bypassed by removing all setup checks, now featured in MediaCreationTool.bat (standalone script available) ;)
    Give it a go, @Carlos Detweiller
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,925
    68,169
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. MIMMO61

    MIMMO61 MDL Senior Member

    Aug 19, 2009
    297
    75
    10
    #573 MIMMO61, Oct 20, 2021
    Last edited: Oct 20, 2021
    Meanwhile, a final solution could be used batch files that directly eliminates the "appraiserres.dll" file during the update?

    Code:
    rem ---------------------------------------------------------------------
    rem   Script that automatically performs administrator privileges
    rem ----------------------------------------------------------------------
    cls
    @echo off
    Color 2f
    echo.
    @chcp 28591 > nul
    ::@mode con cols=101 lines=20
    @Title Execution in Administrator mode
    :: We carry out commands with administrator permissions
    ::------------------------------------------
    REM --> Checking permissions
    >nul 2>&1 "%SYSTEMROOT%\system32\cacls.exe" "%SYSTEMROOT%\system32\config\system"
    REM --> Error you don't have administrator rights
    if '%errorlevel%' NEQ '0' (
    echo     Request for administrator privileges
    goto UACPrompt
    ) else ( goto gotAdmin )
    :UACPrompt
    @echo Set UAC = CreateObject^("Shell.Application"^) > "%temp%\getadmin.vbs"
    set params = %*:"="
    echo UAC.ShellExecute "%~s0", "%params%", "", "runas", 1 >> "%temp%\getadmin.vbs"
    "%temp%\getadmin.vbs"
    exit /B
    :gotAdmin
    if exist "%temp%\getadmin.vbs" ( del "%temp%\getadmin.vbs" )
    pushd "%CD%"
    CD /D "%~dp0"
    cls
    Color 1f
    echo.
    del "C:\$WINDOWS.~BT\Sources\appraiserres.dll" /A /F /Q /S
    exit
     
  14. BAU

    BAU MDL Expert

    Feb 10, 2009
    1,301
    3,588
    60
    I obviously made plenty of tests, using your tool, using rufus, directly editing registry & etc.
    And my machine is not the only one affected, Carlos Detweiller above, others that reported it did not work for them despite following everything to the letter (quickly dismissed, some people here are awfully defensive pff), and some cases I found online. Probably a combination of host BIOS, enabled/disabled virtualization & secureboot features, host windows (10 21H1), and even virtualbox configuration (tho I've tested with new vm's on fresh latest and legacy 5.2.44).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,925
    68,169
    450
    I just created the vm as i always do (not often in vbox, 99% in vmware) and it worked fine.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    5,000
    5,189
    180
    #576 Carlos Detweiller, Oct 21, 2021
    Last edited: Oct 21, 2021
    Here, one for your viewing pleasure:
    Win11_dilemma_VB.jpg

    All Regkeys are in place, yet, I get the message. Legacy or UEFI boot makes no difference.

    Will do and report back.

    [Offtopic] Is Compress2Text 6.3 still the latest version? [/Offtopic]
     
  17. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    5,000
    5,189
    180
    Results are in: The script from @BAU definitely and undoubtedly fixes the above issue. Sneaky MS b*stards have blacklisted some VB stuff in winsetup.dll (maybe only older versions, I'm using 5.4.45), patching is necessary for truly universal media.

    CC @Enthousiast - Might consider incorporating the fix into your tool.
     
  18. rustynails

    rustynails MDL Novice

    Mar 18, 2015
    38
    24
    0
    #578 rustynails, Oct 21, 2021
    Last edited: Oct 21, 2021
    uh oh ...

    im using build win 11 22483 to do this . seems WMIC does not come with it and so ends in this. I see the build just before this one has WMIC in the windows folders System32\wbem and SysWOW64\wbem but not for build 22483. So im guessing this is why im getting ...

    so Ive tried windows update and ISO from UUP dump 22483 on a few systems and its the same.. WMIC.exe is missing....

    " ERROR: Could not delete existing file "22483.1000.211015-1431.RS_PRERELEASE_CLIENTPRO_OEMRET_X64FRE_EN-US_FIXED_~0,4_date:~4,2_date:~6,2.ISO"
    Error 123: The filename, directory name, or volume label syntax is incorrect. "



    ============================================================
    Win 11 Boot & Upgrade FiX KiT v2.0...
    ============================================================


    ================================================================================
    Select the desired FiX...
    ================================================================================

    [ 1 ] - Puts the Win 11 install.wim/esd in a Win 10 ISO (Provide a Win 10 ISO in the "Source_ISO\W10\" Folder)
    This method is usefull for clean installs from boot, using the standard W10 setup. A generic EI.CFG file will
    be copied to the sources folder.

    [ 2 ] - Integrate Diskpart & Apply Image script (v1.3.1), modify boot.wim to skip the SB, RAM, DiskSize and TPM 2.0 check
    and replace "appraiserres.dll" with one from a 1703 ISO. A generic EI.CFG file will be copied to the sources folder.

    This method enables you to:
    - Use the standard Win 11 setup for clean installs on devices without Secure Boot and TPM 2.0 and low amount of DiskSize & RAM.
    - Use the alternative Diskpart & Apply Image installation script for clean installs.
    - Circumvent "TPM 2.0 is required" error when (inplace) upgrading.
    - Enables to install on LegacyBIOS/MBR only systems.
    - Circumvents the 64GB (52GB) minimum disk size check.

    ================================================================================

    * Type your option and press Enter: 2

    Extracting Source ISO...


    7-Zip 19.00 (x86) : Copyright (c) 1999-2018 Igor Pavlov : 2019-02-21

    Scanning the drive for archives:
    1 folder, 1 file, 4381829120 bytes (4179 MiB)

    Extracting archive: Source_ISO\W11\22483.1000.211015-1431.RS_PRERELEASE_CLIENTPRO_OEMRET_X64FRE_EN-US.ISO
    --
    Path = Source_ISO\W11\22483.1000.211015-1431.RS_PRERELEASE_CLIENTPRO_OEMRET_X64FRE_EN-US.ISO
    Type = Udf
    Physical Size = 4381829120
    Comment = CPRA_X64FRE_EN-US_DV5
    Cluster Size = 2048
    Created = 2021-10-16 11:45:17

    Everything is Ok

    Folders: 84
    Files: 937
    Size: 4390238832
    Compressed: 4381829120


    ============================================================
    Adding Murphy78 Diskpart and Apply Image Script 1.3.1 To Boot.wim...
    ============================================================

    Scanning "murphy78-DiskPart-Apply-v1.3.1\x64\"
    525 KiB scanned (5 files, 4 directories)
    Using LZX compression with 1 thread
    Archiving file data: 525 KiB of 525 KiB (100%) done

    ============================================================
    Modding Boot.wim to disable Secure Boot, RAM, DiskSize and TPM 2.0 check...
    ============================================================

    Extracting file data: 6400 KiB of 6400 KiB (100%) done
    Done extracting files.
    The operation completed successfully.
    The operation completed successfully.
    The operation completed successfully.
    The operation completed successfully.
    The operation completed successfully.
    The operation completed successfully.
    The operation completed successfully.
    Scanning "TEMP\SYSTEM" (loading as WIM path: "\Windows\System32\config\SYSTEM")...
    6400 KiB scanned (1 files, 0 directories)
    Updating "\Windows\System32\config\SYSTEM" in WIM image
    Using LZX compression with 8 threads
    Archiving file data: 6400 KiB of 6400 KiB (100%) done

    ============================================================
    Optimizing boot.wim...
    ============================================================

    "WORK\Sources\boot.wim" original size: 428479 KiB
    Using LZX compression with 8 threads
    Archiving file data: 1112 MiB of 1112 MiB (100%) done
    "WORK\Sources\boot.wim" optimized size: 420629 KiB
    Space saved: 7849 KiB

    ============================================================
    Replacing the Win 11 appraiserres.dll with one from a 1703 (15063) ISO...
    (The original file will be renamed to appraiserres.dll.bak)
    ============================================================

    1 file(s) copied.

    ============================================================
    Copying generic ei.cfg to the work dir...
    ============================================================

    1 file(s) copied.


    =========================================================
    Creating x64 ISO...
    =========================================================



    OSCDIMG 2.56 CD-ROM and DVD-ROM Premastering Utility
    Copyright (C) Microsoft, 1993-2012. All rights reserved.
    Licensed only for producing Microsoft authorized content.


    ERROR: Could not delete existing file "22483.1000.211015-1431.RS_PRERELEASE_CLIENTPRO_OEMRET_X64FRE_EN-US_FIXED_~0,4_date:~4,2_date:~6,2.ISO"
    Error 123: The filename, directory name, or volume label syntax is incorrect.
    Press any key to continue . . .
     
  19. BAU

    BAU MDL Expert

    Feb 10, 2009
    1,301
    3,588
    60
    Great news, latest VirtualBox from a day ago (VirtualBox-6.1.28-147628) has fixed the blocking issues with a 11-tuned virtualization profile!
    Not sure what happens with old vm's, but with a fresh one with Windows 11 as a template, unmodified 11 release iso and importing the reg included in VBoxGuestAdditions via shift+f10 it worked.
    Meaning any regular registry-based bypass should work now with latest VirtualBox for any configuration (this kit / rufus / etc).
    While the ultra hex-edit bypass of all setup checks is still ok to use / have as a backup for weird&outdated configurations or older VirtualBox versions (for example I need 5.2.44 for legacy stuff).

    Sorry Enthousiast for the intrusion, but as shown, I was right that there was a scenario where registry bypasss simply did not work
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    5,000
    5,189
    180
    Not was, it still is. VirtualBox 5.2.45 is all I can run. 6.0 crashes, and 6.1 doesn't support Windows 7 as Host OS. Thus, the fix is important.