Win 7 to Win 10 Failed

Discussion in 'Windows 10' started by hellohello, Aug 1, 2015.

  1. hellohello

    hellohello MDL Junior Member

    May 10, 2007
    95
    18
    0
    #1 hellohello, Aug 1, 2015
    Last edited: Aug 1, 2015
    Hi everyone,

    I am using a laptop which was running 8.1 x64 (clean install).

    I don't really like 8 and formatted to windows 7 ultimate 32bit. Since windows 10 is released, I tried to upgrade to pro 32bit and it failed stating the CPU doesn't support NX. Isn't that strange because I thought 8.1 also requires that but it installs just fine? Also, that feature is enabled in the bios.

    Is there any new CPU requirements for 10 like VT-x? Or is there any workaround for this?
     
  2. SpeedDream

    SpeedDream MDL Addicted

    Feb 20, 2012
    619
    121
    30
    what cpu do you have?
     
  3. hellohello

    hellohello MDL Junior Member

    May 10, 2007
    95
    18
    0
    Core 2 Duo T5850

    MMX, SSE, SSE2, SSE3, SSSE3, EM64T, NX / XD / Execute disable bit but no VT-x
     
  4. SpeedDream

    SpeedDream MDL Addicted

    Feb 20, 2012
    619
    121
    30
    try a clean install see if it happens again booting from windows 10 setup dvd or pen drive, not sure about your cpu, requirements are same as 8.1 X64
     
  5. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    why go from x64 to x32 architecture?
     
  6. cuteee

    cuteee MDL Guru

    Oct 13, 2012
    3,235
    410
    120
    Maybe he has 3GB memory or less.
     
  7. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    possibly, but he said he was running 8.1 x64 :rasta:
     
  8. Puffingmad

    Puffingmad MDL Addicted

    Aug 19, 2012
    500
    229
    30
    #8 Puffingmad, Aug 1, 2015
    Last edited: Aug 1, 2015
    Maybe he should put 8.1 x64 back on try doing the upgrade from there
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. fede9_6

    fede9_6 MDL Novice

    Jul 29, 2015
    5
    1
    0
    Try running cmd.exe as Administator then use this command bcdedit.exe /set {current} nx AlwaysOn and restart. It worked for me!
     
  10. hellohello

    hellohello MDL Junior Member

    May 10, 2007
    95
    18
    0
    #10 hellohello, Aug 1, 2015
    Last edited: Aug 1, 2015
    (OP)
    Yep, since it won't benefit from x64, I decided to go with x86

    Sounds like a plan but with 7 SP1 x64 then to 10 Pro x64

    I will try this too

    Thank you everyone

    setting nx to always on solve the problem