Win 8.1 ENT: WiFi Issues on my Lenovo W520

Discussion in 'Windows 8' started by chukwe, Sep 25, 2013.

  1. chukwe

    chukwe MDL Novice

    Aug 1, 2009
    17
    0
    0
    Hi All,

    Since installing Windows 8.1 Enterprise last week Friday, I've had issues with my WiFi ranging from showing "Limited Connection" to very slow page loading.

    This happens both on my home and Work routers.

    Has people been experiencing the same issue
     
  2. mydigitaldesktop

    mydigitaldesktop MDL Junior Member

    Sep 18, 2013
    55
    24
    0
    I think lots of problems have been reported for Intel Wireless drivers.

    My issues went away when I updated to the Intel 16.1.5 wireless drivers from Intel.com

    If you have a different wireless chip, see if you can find updated drivers from the chip makers website...
     
  3. chukwe

    chukwe MDL Novice

    Aug 1, 2009
    17
    0
    0
    My wireless is Intel(R) Centrino(R) Ultimate-N 6300 AGN and it's version is 15.10.3.2.

    Anymore Information? Thanks
     
  4. mick711

    mick711 MDL Junior Member

    Apr 14, 2008
    80
    2
    0
    I have this issu to with 8.1 Pro on my Toshiba T902
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mojsije

    mojsije MDL Novice

    Aug 12, 2012
    2
    1
    0
    I think that problem is in drivers
    because most of drivers do not have support for windows 8.1.
    Try to update your drivers. :)
     
  6. mydigitaldesktop

    mydigitaldesktop MDL Junior Member

    Sep 18, 2013
    55
    24
    0
    Go to Intel.com

    Download 16.1.5
     
  7. Liamsis

    Liamsis MDL Novice

    Sep 22, 2013
    18
    1
    0
    Go to Intel.com
     
  8. chukwe

    chukwe MDL Novice

    Aug 1, 2009
    17
    0
    0
    I downloaded the driver from here intel.

    After installing the driver, it still shows version 15.10.3.2. When I right click the driver from device manager and select "update driver software" it says the driver software is the latest version.

    What have I done wrong?
     
  9. WinDev

    WinDev MDL Expert

    Jul 6, 2013
    1,170
    1,005
    60
  10. Paiva

    Paiva MDL Developer

    Apr 9, 2011
    1,275
    1,455
    60
    Some firewall may be blocking network traffic.

    Regards,
     
  11. mydigitaldesktop

    mydigitaldesktop MDL Junior Member

    Sep 18, 2013
    55
    24
    0
    Download the latest chipset install utility from Intel.com - it's in the "software" dropdown section under drivers

    The routers you are connecting to might be implementing the DLNA media thingie or connecting you to a network which implements it which trips a bug in 8.1 Explorer. There is a registry file you can run to turn that off. On my computer it was horrible. I didn't get the crashing some people get but I had horrible slow downs in the internet and also horrible speed to my external USB drives...
     
  12. chukwe

    chukwe MDL Novice

    Aug 1, 2009
    17
    0
    0
    I've downloaded the Intel chipset utility, but still having the same wifi issue.

    As regarding the Explorer bug , I don't use IE but firefox. Where is the registry entry located?
     
  13. mydigitaldesktop

    mydigitaldesktop MDL Junior Member

    Sep 18, 2013
    55
    24
    0
    Yeah, the overloaded Explorer word... so you have the age old file explorer and instabilities in that causes all sorts of issues on any Windows system.

    In Windows 8 they added the ability to detect DLNA servers on your local network or inside your router etc. See this random link for a screenshot:

    community.twonky.com/twonky/topics/windows_8_has_a_built_in_dlna_client_integrated_into_explorer

    In both the 8.1 Preview and the 8.1 RTM there is a bug which causes the file explorer to crash or in my case just cause serious network slowdowns and also constant dropping of external USB drives.

    For me just editing the registry worked just fine, but you can also rename DLL both of which are shown in this Microsoft support forum:

    answers.microsoft.com/en-us/windows/forum/windows8_1_pr-files/dlnashextdll-causing-explorer-to-crash/9b2442c2-4ac1-4cb5-8e0d-35ba9b8ccacd
     
  14. mydigitaldesktop

    mydigitaldesktop MDL Junior Member

    Sep 18, 2013
    55
    24
    0
    DLNA maybe causing a lot of unsuspected issues

    As a general note, my personal suspicion is that the DLNA bug is causing many of the unknown slowdowns and weird issues a lot of people are finding in 8.1 but it is only identified as a culprit when it crashes explorer.

    It might also be that IPV6 is connected somehow since 8.1 seems to want IPV6 turned on and I hate IPV6 with a passion and have it turned off wherever I can but it keeps surfacing like it wants a career as a virus... so perhaps explorer is going nuts trying to make a bunch of IPV6 tunnels in it's quest to discover every DLNA service that it possibly can....

    Anyways this is just idle speculation at the moment...
     
  15. Chew7bacca

    Chew7bacca MDL Novice

    Aug 6, 2010
    24
    4
    0
    I am having some of these problems with my Centrino too but only when reconnecting to WiFi after sleep. Get "Limited" connection and a hot CPU that never mellows out until reboot. Task manager only shows "System" as the resource hog (31%). Going to play with drivers tonight. Thanks everyone.
     
  16. WPNettwerk

    WPNettwerk MDL Novice

    Aug 6, 2012
    23
    4
    0
    I had problem with Windows 8, but since I installed Windows 8.1 problem gone. Mostly Intel Wireless cards has problem with 5Ghz network. If you have setup 5Ghz network turn it off and try setup 2.4Ghz network and find best channel for your card. My configuration is 2.4Ghz network channel 6. No issues yet. And yeah second bigest problem for Intel wireless card is D-Link routers. I did use three of D-Link routers when I swap to Linksys/Cisco no problem (Limited Access etc).
     
  17. generalsu

    generalsu MDL Senior Member

    Jul 30, 2009
    265
    12
    10
    Do you have your Win 8.1 ENT activated? If yes, how?
     
  18. WPNettwerk

    WPNettwerk MDL Novice

    Aug 6, 2012
    23
    4
    0
    I have 8.1 Pro version. There isnt diference between Pro or Ent. Both uses same drivers.
     
  19. generalsu

    generalsu MDL Senior Member

    Jul 30, 2009
    265
    12
    10
    You got Pro Retail or VL?
     
  20. WPNettwerk

    WPNettwerk MDL Novice

    Aug 6, 2012
    23
    4
    0
    I have Pro retail from Technet.