Win 8 host, Win 7 VM - Bridge networking no net

Discussion in 'Virtualization' started by lunar21, Oct 19, 2012.

  1. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    I have a Win 8 host and a Win 7 VM. NAT works perfectly but when I switch to bridge I get an IP, router is able to see the VM but there is no internet. What do I have to do to make the internet work? BTW it also does not work in any other VM that I have.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. user_hidden

    user_hidden MDL Expert

    Dec 18, 2007
    1,026
    973
    60
    what virtualization software...Vbox, VmWare...???
     
  3. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    Ok got internet now on my bridged connection. It was Bitdefender firewall blocking it so i just turned it off. Now the problem is that I am trying to use no-ip to make my KMs available to me outside of my network. Problem I am facing is that for some reason, even tho my port is forwarded to my VM, I am still unable to get access to my server. Please help me out, if anyone knows how, to fix this problem. Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. CODYQX4

    CODYQX4 MDL Developer

    Sep 4, 2009
    4,801
    44,951
    150
    #4 CODYQX4, Oct 27, 2012
    Last edited: Oct 27, 2012
    I have a similar issue. I use W8 Host and W8 VM on VMware 9 Workstation. I can set it to NAT to get internet, but if I go bridged, I stay in limited. My router will see the MAC, then see the MAC as all 0's. Then VM will eat another IP. It will consume every IP in the DHCP pool if allowed. It will also say if you run ipconfig that the IP is already in use, even if it is the first IP.

    Also trying to do this for KMS purposes.

    EDIT: Connectify LightWeight Filter on your real NIC breaks Bridged. Disable it if you use Connectify. Don't know how that will affect Connectify.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. adit123tya

    adit123tya MDL Senior Member

    Oct 25, 2012
    397
    197
    10
    I had a similar problem... uninstalling and reinstalling VMware worked
     
  6. deanmart

    deanmart MDL Novice

    Aug 10, 2009
    7
    3
    0
    No need to reinstall VMware.
    Open VMWare Window, do not start any guest.
    Go to EDIT->Virtual Network Editor.
    In the Network Editor Select Automatic Settings Tab for Bridged Networking, uncheck any Virtual Adapters (Like connectify, Microsoft Virtual Wifi etc).
    Make sure that only physical adapters are selected.
    Apply settings.
    Restart VMware and you should be good with bridged networking.