Win10 bug on my Acer 7750G laptop - MSDN .iso clean install

Discussion in 'Windows 10' started by myhken, Aug 13, 2015.

  1. myhken

    myhken Experienced MDL Tester

    Feb 28, 2010
    919
    635
    30
    I have updated some of my virtual computers to Windows 10 (clean install from MSDN .iso (I'm a member). No issue at all.
    But on my laptop (Acer 7750G, 2012 model) I have a strange problem.
    When I restart the computer, Windows 10 is loading fine, then the screen gets black, then it stays black for 3-5 minutes, then Windows goes to login.
    Same happens when I put the laptop in sleep mode or hibernation, it's showing the black screen (but not off black, but the screen is on black).

    Anybody have the same issue, or have a solution on it?

    No drivers is missing (no yellow signs in device manager). Totally clean install from USB stick with original MSDN .iso file (from my own account). Windows 10 Pro 64bit.

    The disk is not working when the screen is black, but start to work just before the login page gets there. So no disk activity for 3-5 minutes, after a normal Windows load up till that point.
     
  2. Rock Hunter

    Rock Hunter MDL Senior Member

    Dec 6, 2011
    406
    99
    10
    #2 Rock Hunter, Aug 14, 2015
    Last edited: Aug 14, 2015
    Acer's web site has drivers for Win 7 and Win 8. No drivers for Win 8.1 or Win 10.

    Their web site has this notice:

    Windows 10 UpdateAcer will provide driver support for the following products that qualify for the Windows update:

    • Your system may require additional software, firmware, and/or a BIOS update to install and run Windows 10. Please note not all Windows 10 features may be available on all Windows 8 PCs. See the following qualifying Acer models. Systems not specified won’t be supported for an upgrade to Windows 10 in line with Microsoft’s regulations.


    I didn't see your model listed so it looks like a no go for Windows 10.
     
  3. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    453
    60
    #3 odiebugs1, Aug 14, 2015
    Last edited: Aug 14, 2015
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. myhken

    myhken Experienced MDL Tester

    Feb 28, 2010
    919
    635
    30
    Updated to newest AMD driver, and the Intel driver was the newest (the laptop has dual GPU), same issue.
     
  5. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,373
    15,025
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...