win7 VM on 2008 server R2

Discussion in 'Virtualization' started by stefa, Sep 10, 2011.

  1. stefa

    stefa MDL Novice

    Sep 10, 2011
    3
    0
    0
    Hi

    I've installed win 7 ultimate on a 2008 server R2 . As rearm count reach 0, I run windows loader from win7 VM but now virtual machine doesn't start anymore. When I start VM from Hyper-V manager i get a black screen with a blinking cursor. Any suggestions to repair the virtual machine?

    Thanks
     
  2. Daz

    Daz MDL Developer / Admin
    Staff Member

    Jul 31, 2009
    9,490
    66,580
    300
    #2 Daz, Sep 10, 2011
    Last edited by a moderator: Apr 20, 2017
    The loader doesn't work on Hyper-V.

    You can repair it by setting up the VM to boot from DVD. Next go to the repair options, select command prompt and use this command:
    Code:
    bootsect.exe /nt60 sys /force
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,935
    1,803
    180
    And then read the sticky:

    Hyper-V Pre-Activation Solutions Roundup

    sebus
     
  4. stefa

    stefa MDL Novice

    Sep 10, 2011
    3
    0
    0
    First of all, I want to thank you all for replies. Excuse me for troubling you and my bad english.

    How can I boot VM from DVD? I have the following setings of VM:

    IDE Controller 0
    Hard Drive: Win7.vhd
    DVD Drive: Physical drive F

    I've already tried with a bootable win7 DVD but didn't work. The same with the iso DVD? Any guidelines?

    Thanks a lot!
     
  5. stefa

    stefa MDL Novice

    Sep 10, 2011
    3
    0
    0
    It works!

    I checked and I've been using the wrong dvd.

    Thanks!