Win7x64: 15 => 20 minutes to go into hibernate?!?!?

Discussion in 'Windows 7' started by AzJazz, Mar 30, 2011.

  1. AzJazz

    AzJazz MDL Novice

    Oct 24, 2009
    18
    0
    0
    I have an Asus P6T-Deluxe V2 motherboard with a Core i7 920 CPU and 6GB RAM and a RAID-5 hard drive array.

    When I try to enter Hibernate mode, it takes around 15 to 20 minutes to get into hibernate before the PC turns off.

    What is going wrong?

    AzJazz
     
  2. burfadel

    burfadel MDL EXE>MSP/CAB

    Aug 19, 2009
    2,628
    3,842
    90
    I take it you are updated with SP1 plus all the updates?

    Have you got all your drivers updated, like the Intel AHCI drivers? - I'd be surprised if you are running in RAID IDE compatibility mode... not a good idea! The Intel RAID driver is separate but related to the AHCI, and part of the same driver set. Of course, should use the INTEL RST drivers for that. Latest is 10.1.2.1004. All other drivers should be updated too.

    Are you using the 1108 bios (the latest), if not, update :)

    There are two standby modes where the computer turns off. The first is the commonly known hibernation (S4 standby). Hibernation is ideal for laptops, because its a battery consideration of reloading Windows etc, and also if the battery goes flat it makes a hard copy (hibernation) of Windows and doesn't drain any more battery. Hibernation saves the entire contents of the RAM to the HDD, but doesn't save free memory or file cache information (I believe...). So, it should only take the time to save say, 1.5GB if you have some programs open, instead of saving 6gb. The disadvantage is it takes time to shut down and start up, and permanently leaves a 6gb file on your HDD. Because it doesn't store filecache information, or superfetch information, it needs to reload this once you resume from hibernation, which takes time and more HDD use. If you dissable program superfetch by setting 2 in the registry (never turn off the service), the filecacheing basically works like superfetch except data isn't reloaded if it is replaced by something else. In a changing memory environment this saves a lot of unnecessary HDD use, at the expense of slightly longer (that is, pretty much normal) load times if you haven't loaded a program for a while in that particular Windows session.

    *** In fact, regardless weather you use hibernation or not, a hibernation file is automatically created and takes up the disk space for the size of whatever your RAM is. To delete, from the command prompt, type:
    powercfg -h off

    The second type is suspend to RAM (S3 standby). This is more suited for desktops. Suspend to RAM standby does not save the whole contents of the RAM (in your case, 6gb) to the HDD. What STR does is literally turns the whole computer off, BUT keeps a tiny trickle of power to the RAM, which means it keeps the information viable. When you turn the computer back on its almost instant (quite literally) and all the filecache etc information remains intact. You will lose whatever you have open though if there is a power failure. Power failures aside, STR is much more beneficial and has been around for a long time, ever since XP! I first used STR back in 2003, if that gives you any idea. Hardware has to be compatible with it, and I was lucky mine was at the time. These days, pretty much everything is compatible with STR. STR is an option in the bios, you can either set it to S1 (where the computer stays on, but is in 'standby'), or S3 (computer turns off, trickle of power to the memory). These two different types are triggered the same way, either as part of the power profile, or selecting standby in the start menu.

    Don't be worried about 'the computer being on' with STR, such as during a thunderstorm, because there is quite literally power running through your motherboard all the time. If your LAN has a light on it, and connected, that will flicker due to network activity when the computer is off! - afterall, you can set the computer to start remotely by LAN. The more logical way to think of it is, think of the power button on the front of the computer. Where do you plug the power switch in to? the motherboard! not the PSU.

    Downside of STR is sometimes overclocks may not reset back to their full speeds, since STR is actually as much a bios driven thing as a Windows driven thing. If thats the case, its more to do with a bios bug than anything to do with Windows. Anyways, STR is the better choice :D unless you run in to that problem.

    I don't know the validity behind this, and I think they were looking for a similar thing with Windows 7, but with Windows 8 I think STR is going to be the standard Shut down method? simply because it literally means a 2 second or less instant-on. If this is set up though, its most likely it would be set to clear the RAM contents back to a pre-start equivalent, as part of the shutdown cycle.

    In any case, it looks like something is preventing the hibernation, probably the RAID setup... but it would proably respond much better to STR.
     
  3. AzJazz

    AzJazz MDL Novice

    Oct 24, 2009
    18
    0
    0
    Hi, burfadel!

    I am running the latest P6T-DV2 BIOS (1108). I updated my AHCI drivers a couple of months ago (Feb-2011), and didn't see any difference in this problem. In fact, from what I remember, I have always seen this problem - even before I installed my RAID array.

    I have also had problems going into a more normal Standby Mode (STR) - The computer will shut down, but I can't power it back up at all without unplugging power from the system and letting the RAM clear. After that, the system will power back up, but then go through a hard drive corruption check.

    I have not updated Win7 at all from the stock release. I'm not a big fan of MS updates, unless I have a specific problem or there has been a significant feature update. I prefer to search the MS Knowledge Base to "spot-treat" a problem if I have one (I installed KB977178 to fix a problem with Sleep mode crashing on resume due to large SATA drive size). I ran WinXP SP2 perfectly fine for years until recently with only 2 patches.

    However, I haven't seen any Win7x64 patches listed in the MS KB with regards to slow hibernation issues.

    As an additional note, performing a "Standby" will shut my monitor down in seconds, but it takes over 3 minutes for the system to actually shut down. A ton of hard drive activity is going on during the shutdown (similar to what happens for the hibernate).

    Cheers,

    AzJazz
     
  4. AzJazz

    AzJazz MDL Novice

    Oct 24, 2009
    18
    0
    0
    Hi, guys,

    I'm still having this problem, and still fishing for a solution ... :fishing1:

    Any ideas?
     
  5. thatguychuck

    thatguychuck MDL Member

    Feb 6, 2011
    100
    34
    10
    #5 thatguychuck, Apr 13, 2011
    Last edited: Apr 13, 2011
    I have seen this behavior before, but it was on a Biostar board with an Sempron processor running a core unlocker. There is a bug in the biostar bios that was causing it, after some searching I came across this reply from Biostar:

    "We want to help customer anytime. But, the ACC function did open AMD CPU Kernel Bug, so it may be enabled some no handle bugs, there. So, we unable to help fix it when customer enabled ACC function, then used S3 resume. This is because S3 need to record some system functions and CPU information. But, CPU information did change to no AMD CPU Table list CPUs. So, it will make S3 resume failed when compare to BIOS internal CPU original Table."

    So for me, everything worked fine with AAC off, but not on. Eventually I picked up a different processor and didn't need the aac anymore. I know the equipment is quite different, but the problems sound about the same. The "tables" being talked about in the reply from biostar are beyond my scope of knowledge, but the mismatch was causing the problem. This might not help you, but wanted to add my .02

    Regards,

    Edit: I think since the core unlocker is considered an "overclock" function, they don't have any real desire to fix the bug. If you are overclocking at all, maybe try going back to stock and see if it helps.