Windows 10 and auto rotation on tablets not working

Discussion in 'Windows 10' started by mrbbq, Sep 4, 2015.

  1. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10
    I am sure a few of you have probably encountered this by now. As an example, if you have ever tried installing Enterprise LTSB on a tablet, you are likely to find that the screen orientation is not auto-rotating even after installing the relevant drivers (eg. Kionix sensor), and there is no option under Settings -> Display for auto rotation as there is under the non-LTSB version of Enterprise. Meaning that for tablet users, Enterprise is pretty much required instead of LTSB if you want auto rotation to work.

    Last night having run the "Destroy Windows Spying" tool, this option has disappeared from my Enterprise install too, with the same non auto rotating behaviour seen in LTSB.

    So; Is it a registry key that makes the wonderous auto rotation checkbox appear on the Settings -> Display screen? A service? Some random "app" whose removal upsets it?

    I would love for someone to look into this, as obviously if whatever it is can be identified, along with "fixing" it and reenabling the option, it may allow tablet users the option of using LTSB with auto rotation too. Surely a thing worth trying..?
     
  2. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240
    #2 PaulDesmond, Sep 4, 2015
    Last edited: Sep 4, 2015

    already quoted here about same thing: http://forums.mydigitallife.net/thr...-(DWS)/page2?p=1137790&viewfull=1#post1137790

    Windows 10 allegedly carries a code called "ReadingTransform" where Microsoft promises that one line of code is enough to run an app with perfect rotation performance on all new devices. If it really works ....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,855
    3,957
    180
    #3 MrMagic, Sep 4, 2015
    Last edited by a moderator: Apr 20, 2017
  4. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10
    And I rewrote it as I thought this was worth its own topic rather than burying it away, just removed the original post. #timing.
     
  5. sps

    sps MDL Member

    Feb 6, 2008
    126
    33
    10
    Same happened here to asus tablet after applying OO Shutup10
    Maybe it is related to location services (like GPS / sensors)?
     
  6. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240
    certainly not since I never touched the inside of W10 on that particular tablet. Seems that older drivers are not supported but let us dig into that until it auto-rotates again
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10
    #7 mrbbq, Sep 4, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
  8. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10
    #8 mrbbq, Sep 4, 2015
    Last edited: Sep 4, 2015
    (OP)
    Just found something VERY interesting going off of the previous post about OOSU10; out of curiousity I ran OOSU10 and used it to restore the default options instead of disabling everything... And rotation has come back, as has the option in the Display settings for lock enable/disable.

    Worth some digging after all. So now, if the specific setting causing it can be found, we may have a `fix` of sorts and I'll perhaps see if doing the same (OOSU10 -> disable/reenable everything) might kick LTSB into working even.
     
  9. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240

    hasn't worked for me either, now the click even disappeared ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,855
    3,957
    180
    Check in Win32 resolution settings for a check box allowing auto rotate once you install that file
     
  11. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10
    #11 mrbbq, Sep 4, 2015
    Last edited: Sep 4, 2015
    (OP)
    I experimented again by disabling everything with OOSU10 again, and it HAS disabled auto rotation from working again. So there IS something it does, which DWS also does, that causes it. Now its a matter of identifying which particular setting causes it..!:tea: If it can be isolated which checkbox causes it, the makers of both could be informed and possibly work around it or at least provide disclaimers.
    Then of course there's the possibility that an enable/disable might trick LTSB into working properly too.
     
  12. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240

    there is no such box but it worked with 8.1 and earlier OSes
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,855
    3,957
    180
    Strange, maybe different tablet needs a different auto rotate file, mine is a cheapy Bush MyTablet and that file gives me back auto rotate

    But I don't bother with it now as I always use the tab in landscape, so I just use Intel display settings to set it to 270dg and leave auto rotate disabled
     
  14. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10
    The box is a new addition in 10 when auto rotation is working. I'm trying to isolate which checkbox in OOSU10 causes auto rotation to stop working now. Very tedious as it means rebooting after every change to see if it still works, but getting there.
     
  15. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,855
    3,957
    180
  16. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240
    here it is Render tablet China made with Pegatron sensor used for fun and test only and that check box doesn't exist under W10
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10
    #17 mrbbq, Sep 4, 2015
    Last edited: Sep 4, 2015
    (OP)
    It does not appear unless auto rotate is working. Anyway I think I've found the setting. Just one quick test...
    (And I shall certainly look into that LTSB thing shortly.)

    EDIT: DING! We have a winner. And it IS a location related thing in O&O SU10. "Disable sensors for locating the system". They describe it as GPS related, but it must knock out the orientation detection for Windows too. You can enable everything else just fine, but change that single setting and reboot and auto rotation will stop working.

    So, Paul or someone who currently does not have auto rotation working, try running it and changing that one setting. If it's enabled by default, disable it (you want it to have the red checkbox) and reboot. See if that helps.
     
  18. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    171
    49
    10