Windows 10 Automatic driver installation

Discussion in 'Windows 10' started by shoteye04, Mar 9, 2016.

  1. shoteye04

    shoteye04 MDL Junior Member

    Oct 17, 2014
    50
    5
    0
    Ok here what is the problem:
    1.After clean install my laptop (Win 10 build 1511).I use minitool updater to set the update mode to notification mode.after successfully set it.
    2.I install drivers i downloaded from specific sites like intel /nvidia and install it.
    3.Even though i set it to notification mode still drivers is downloaded at background,not through windows update but background.
    4.In task manager i see that svchost process is using my internet.

    So how can I completely block the automatic driver updates?
    If anyone have solution for this pls help.tq.:)
     
  2. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    15,444
    18,496
    340
    In 8.1 there was an option during express settings/oobe, i don't know (without checking) if the option is still there in 10, it was something called: Allow driver updates.
     
  3. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,107
    492
    60
    There is simply no way to block driver updates. Micro$h4ft want to play the drivers God and choose the drivers for us. See my thread here, I initially thought I solved the mystery but nope......no reg edit/ tweak/setting/group policy rule will prevent drivers from automatically being updated.

    the only way around this is you have to download the latest driver and install them yourself before connecting to the internet. If any driver update is found, you will be forced to update it:
    http://forums.mydigitallife.net/thr...isable-automatic-driver-updates-in-Windows-10
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Full inu

    Full inu MDL Senior Member

    Jun 9, 2015
    487
    125
    10
    #4 Full inu, Mar 9, 2016
    Last edited by a moderator: Apr 20, 2017
    It doesn't work, driver will be instaled with other updates anyway (when searching for them manually, for example).

    I hate Windows 10 so much for this.
     
  5. shoteye04

    shoteye04 MDL Junior Member

    Oct 17, 2014
    50
    5
    0
    I think there's no option for this in win 10,but will see on next clean install.Thank u.
     
  6. shoteye04

    shoteye04 MDL Junior Member

    Oct 17, 2014
    50
    5
    0
    Even though i use updated graphic driver it still download old intel graphic driver.
     
  7. shoteye04

    shoteye04 MDL Junior Member

    Oct 17, 2014
    50
    5
    0
    #7 shoteye04, Mar 9, 2016
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Will try it on next clean install.Thank u.
     
  8. picolocris

    picolocris MDL Novice

    Jun 11, 2015
    7
    31
    0
    techpowerup.com/forums/threads/windows-10-tweaks.214172/#post-3316914
     
  9. mysteriously

    mysteriously MDL Member

    Jun 11, 2012
    188
    67
    10
  10. Enzo Matrix

    Enzo Matrix Guest

    This works for me:
    Unplug internet or don't log into wireless when installing 10.
    Run driver installation settings and select no.
    regedit - set driver searching to 0.
    Go online, run windows 10 hide update tool from microsoft.
    install drivers you have downloaded
    then run hide update tool again and make sure no hardware remains there.
    Then use Windows update and it should only have different software and microsoft updates.
    There should be no more hardware updates, keep hide update tool and run it now and then just to check but you should be fine.