Windows 10 Date

Discussion in 'Windows 10' started by cyberbot, Sep 7, 2015.

  1. cyberbot

    cyberbot MDL Senior Member

    Jul 30, 2011
    463
    20
    10
    Hi Guys,
    using excel 2013 in one of my windows 10 machine, however windows 10 date formate is dd/mm/yyyy but excel is still seeing it as mm/dd/yyyy
    tried to change the date on windows settings and excel but its still not changing.
    any suggestions how to fix this ?
    thank you
     
  2. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    454
    60
    #2 odiebugs1, Sep 7, 2015
    Last edited: Sep 7, 2015
    So in settings you've changed format and it doesn't work ?.

    HKEY_CURRENT_USER\DEFAULT\Control Panel\International
    Value name: sShortDate, Value data: dd/MM/yyyy (or any other format)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cyberbot

    cyberbot MDL Senior Member

    Jul 30, 2011
    463
    20
    10
    yes on the right corner of my windows it says 07-09-2015
    and the VAPProject on excel is

    TextBox6.Value = Format(Date, "dd-mm-yyyy")
    TextBox7.Value = Format(DateAdd("d", 30, TextBox6.Value), "dd-mm-yyyy")
    TextBox8.Value = Application.VLookup(Me.ComboBox1, Sheets("Addresses").Range("A:G"), 7, False)
     
  4. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    454
    60
    #4 odiebugs1, Sep 7, 2015
    Last edited: Sep 7, 2015
    Have you tried format cells -Custom

    Select the column containing the dates, go to Data and choose Text to Column, choose delimited and click next
    and uncheck all delimiters and click next, Click on date and choose right format for the dates (default DMY).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cyberbot

    cyberbot MDL Senior Member

    Jul 30, 2011
    463
    20
    10
    how I am supposed to do this ?
    can you explain please ?
     
  6. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    454
    60
    #6 odiebugs1, Sep 7, 2015
    Last edited: Sep 7, 2015
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. RCM

    RCM MDL Junior Member

    May 15, 2010
    86
    50
    0
    You can change it in excel, right click on cell or group of cells, chose format cells, click on "date" then choose the format you want.
     
  8. cyberbot

    cyberbot MDL Senior Member

    Jul 30, 2011
    463
    20
    10
    #9 cyberbot, Sep 7, 2015
    Last edited: Sep 7, 2015
    (OP)
    managed to fix
    somehow Office updates f**ked up my computer.
    empty the temps and rebooted everything start working
     
  9. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    454
    60
    Wow, thank goodness it wasn't one of them and it was temp folder, I have I think a hundred updates for office.

    Glad it worked out and you're all set, honestly wasn't thinking of this one, could have run through too many things to try.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. cyberbot

    cyberbot MDL Senior Member

    Jul 30, 2011
    463
    20
    10
    thank you for even trying to help me,
    yes those updates can be bad sometime