Windows 10 keeps resuming from sleep

Discussion in 'Windows 10' started by digitalnemesis, Aug 3, 2015.

  1. digitalnemesis

    digitalnemesis MDL Novice

    Sep 13, 2013
    29
    0
    0
    On Windows 8.1 my computer didn't resume from sleep automatically. it stayed asleep...
    On Windows 10 something is causing my computer to resume from sleep.

    I've disabled all wake from sleep options for every device in device manager such as mouse, keyboard, etc...
    I've disabled the Windows 10 maintenance program
    In event viewer the wake source is always 'unknown'.
    I've disabled wake on LAN options on the network adapter.
    I've disabled wake timers in power options.
    I've checked powercfg -lastwake and it doesn't show what was the cause
    I've checked powercfg -wake_armed and I've disabled everything there
    I've checked scheduled tasks and nothing.

    Still Windows 10 keeps resuming...

    Anything else I should check? Could this be a driver issue?
     
  2. Fckr

    Fckr MDL Member

    Feb 4, 2011
    179
    78
    10
    Possibly. BTW, what's your GPU model?
     
  3. Edwe

    Edwe MDL Member

    Sep 1, 2011
    143
    10
    10
    Run this command in an elevated command prompt to see what last woke the computer up:

    powercfg /lastwake
     
  4. anxiousape

    anxiousape MDL Novice

    Jul 30, 2009
    15
    4
    0
    After having the same issue on a preview release, I stumbled upon msft website solution that suggested restoring default settings of the power profile that's in use. It worked for me.
     
  5. digitalnemesis

    digitalnemesis MDL Novice

    Sep 13, 2013
    29
    0
    0
    I already did that as I said in my first post.

     
  6. digitalnemesis

    digitalnemesis MDL Novice

    Sep 13, 2013
    29
    0
    0
    An old GTX 275.
     
  7. free1975yuly

    free1975yuly MDL Expert

    Aug 24, 2011
    1,757
    149
    60
    I bought an Asus K555 laptop a month ago and I have the same issues with computer sleep:Random awake random sleep.I saw this last night.:eek::eek::eek:
     
  8. 2574

    2574 MDL Junior Member

    Feb 23, 2010
    57
    24
    0
    #9 2574, Aug 3, 2015
    Last edited by a moderator: Apr 20, 2017
    What about this? :
    Code:
    powercfg -waketimers
     
  9. digitalnemesis

    digitalnemesis MDL Novice

    Sep 13, 2013
    29
    0
    0
    #10 digitalnemesis, Aug 3, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)

    It found the teamviewer service so I disabled it in service manager.

    Everything seems okay now. No more sleep resume issues so far.
     
  10. Mutagen

    Mutagen MDL Addicted

    Feb 18, 2013
    580
    123
    30
    Wish I could resume from sleep. Lately, I'm lucky to be up at the crack of noon.
     
  11. buendia

    buendia MDL Novice

    Jul 28, 2009
    34
    2
    0
    Yep, the latest TeamViewer did that to me too. I circumvented it by installing older version.