Windows 10 messing with filesystem and ACLs

Discussion in 'Windows 10' started by nexus76, Sep 25, 2015.

  1. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    #1 nexus76, Sep 25, 2015
    Last edited: Sep 25, 2015
    Hi,

    maybe someone else noticed the same:

    When you create folders on your data volume the ACLs structure gets ruined and files or folder are non-writeable from windows 7.
    The default ACLs are definetely killed. My whole 4TB volume is a mess now, I noticed it installing apps, it shows "notepad++.exe" already exists and so on.
    Even it's impossible to overwrite data without taking over the whole volume, which is pretty timeconsuming and senseless, as windows 10 is messing it up again the next time. I already tried that and reset ACLs to fix it.

    Also another serious filesystem fault is still there:

    Booting windows 10 and afterwards windows 7 leads to a chkdsk of all volumes.
    Windows 10 appears to mark the dirty bit at shutdown or so, or unmounts unsober ...

    Thanks in advance for your response about those ntfs issues.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. endbase

    endbase MDL Guru

    Aug 12, 2012
    3,423
    867
    120
    That is nasty indeed I hope somebody will have an fix for you :tea:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    #3 nexus76, Sep 25, 2015
    Last edited: Sep 25, 2015
    (OP)
    The windows 7 user account is definetely removed from access list.
    And I mean for the whole 4TB.

    Haha, I made the stupid mistake to boot windows 10 to test the freshly compiled infiltrator demo with dx12,
    which is indeed running absolutely lousy compared to windows 7! :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. hanzzon2

    hanzzon2 MDL Member

    Dec 1, 2007
    112
    20
    10
    You need to disable fast boot.
    It's a crazy system that means changes/commits to your filesystem might reside in a pagefile when Win10 is "shutdown"
    So when you boot Win7 and make some changes to the filesystem, and then "boot" Win10 those changes will be f***ed up by the filesystem data that resides in the pagefile.
    Learned this the hard way through massive filesystem corruption!
     
  5. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30

    fastboot isnt enabled
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. lostpassword

    lostpassword MDL Member

    Nov 21, 2009
    190
    13
    10
    Sorry I am totally lost on this thread, would some kind person explain the problem in Simple English.
    I am not running 7 now, only 8.1 and 10. I do not have any drives larger than 3TB, is this the reason I have not seen this problem?

    Not sure what fastboot is, whenever I installed 10, I installed 7 activated with DAZ Loader, and then installed 10 as instructed on posts above. I did have some help from one kind member. No problems writing between drives on my Home Network and also external drives used with WD Player on my TV, although Windows always says there is a problem after using on TV, but everything seems to work. The trick to solve it if a folder cannot be deleted, is to rename folder and that usually works.
     
  7. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    #7 nexus76, Sep 26, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
    dirty programming!

    although windows 10 didn't chkdsk at bootup the dirtybit is set:

    Code:
    C:\WINDOWS\system32>fsutil dirty query C:
    Volume - C: ist fehlerhaft.
    
    C:\WINDOWS\system32>chkntfs c:
    Der Typ des Dateisystems ist NTFS.
    C: ist fehlerhaft. Sie können die Option /C verwenden, damit CHKDSK
    für dieses Laufwerk ausgeführt wird.
    
    indeed bad programming!

    can you gimme some of your results from

    fsutil dirty query C:

    and

    chkntfs C:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Engineer2k2

    Engineer2k2 MDL Member

    Jun 21, 2012
    243
    40
    10
    #8 Engineer2k2, Sep 26, 2015
    Last edited: Sep 26, 2015

    Fastboot is enabled by default - one has to disable it by going to Control Panel>System & security>Power Options>Choose what the power buttons do>Shutdown settings (Go down on the page)>untick check box "Turn on fast startup (Recommended)". ;)
     
  9. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...