Windows 10 "Preparing Automatic Repair" loop possible fix

Discussion in 'Windows 10' started by Das_Human, Feb 20, 2018.

  1. Das_Human

    Das_Human MDL Junior Member

    Apr 6, 2010
    90
    12
    0
    #1 Das_Human, Feb 20, 2018
    Last edited: Feb 20, 2018
    IMPORTANT NOTE:
    This post's intent is TO INFORM AND POSSIBLY HELP someone with the same issue. This post's intent is NOT to seek help or flame.
    Thanks for understanding!

    A little background story.

    Hardware and software used:
    A new Dell Vostro 5471 notebook (with UEFI boot and Secure Boot enabled)
    Fresh and clean Windows 10 Pro (x64; downloaded not so long ago via MediaCreationTool.exe)
    PC has NVME drive and HDD (Windows is on the NVME)​

    After installing all the stuff needed (to put a cheery on top :) ) I've decided to install HFS+ driver (from Apple Boot Camp v6.0.1.0) as I usually do (to be able to read a disk with OS X install). Rebooted the PC (a required step for the driver to work), and to my horror (took me 24 hours plus to install it) encountered the infamous "Preparing Automatic Repair" loop.

    To troubleshoot the issue googled it. Neither of the suggested options seemed to be acceptable (given the amount of time spent installing and configuring all the stuff). So as a frantic attempt to somehow boot the OS (it refused to boot even in the safe mode) I've disabled Secure Boot in BIOS but kept UEFI boot enabled. Rebooted and guess what?! It booted just fine! What a relief!

    Upon further investigation (reading C:\Windows\System32\LogFiles\SrtTrail.txt) I've found out the root cause of the reboot loop.
    Code:
    Root cause found:
    ---------------------------
    Boot critical file d:\windows\system32\drivers\applemnt.sys is corrupt.
    After deleting AppleMNT.sys (and AppleHFS.sys as per instructions provide with the HFS+ driver) and enabling back the Secure Boot in BIOS, PC booted just fine. Again, what a relief! :)

    The moral of the story:
    If your Windows 10 PC has Secure Boot enabled and you encounter the reboot loop, try disabling Secure Boot while leaving UEFI boot enabled (provided the BIOS has such option). Who knows, it might fix the problem.
     
  2. macnavarra

    macnavarra MDL Member

    Nov 13, 2017
    150
    28
    10
    windows installation:

    Install in UEFI mode: Remove the bootmgr file from the root of the Windows Setup media. This prevents the device from starting in BIOS mode.
    Install in BIOS mode: Remove the efi folder from the root of the Windows Setup media. This prevents the device from starting in UEFI mode.