Windows 10 with UAC disabled

Discussion in 'Windows 10' started by purpleman2k, Jul 27, 2015.

  1. purpleman2k

    purpleman2k MDL Novice

    Jul 29, 2009
    2
    0
    0
    Hey everyone.

    Quick question - I'm running Windows 10 with UAC disabled (set to "never notify"), and my user account is a member of the group Administrators. In spite of that, whenever I run a program - it runs without administrative privileges.

    For example, if I run notepad and try to edit the hosts file, it says "access denied" and I have to manually run Notepad "as an administrator".

    Another example is when I try to copy files using File Explorer, I'd get a prompt notifying me that I have to grant administrative rights (which I can, and do).

    In Windows 7, if you disabled UAC everything was automatically elevated. Is there a way to have everything elevated in Windows 10?

    Thanks
     
  2. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,674
    10,073
    210
    I think it's probably because explorer is being run without admin privileges. It's the default situation.
    You can run admin prompt and restart explorer. I don't remember how. I did it once by accident and I remember it causing problems.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. purpleman2k

    purpleman2k MDL Novice

    Jul 29, 2009
    2
    0
    0
    There's gotta be a simpler way. It doesn't make sense that I'll have to specifically elevate each task I'm running.
     
  4. jingyu9575

    jingyu9575 MDL Novice

    Oct 3, 2014
    2
    0
    0
    #4 jingyu9575, Sep 3, 2015
    Last edited: Sep 3, 2015
    Run "secpol.msc", Local Policies -> Security Options, set "User Account Control: Run all administrators in Admin Approval Mode" to Disabled and reboot. This will really disable UAC, not only hiding the notifications.

    WARNING: Metro apps don't work with UAC disabled.
     
  5. M0rriss0n

    M0rriss0n MDL Senior Member

    Sep 17, 2011
    318
    96
    10
    For me:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLua
    set value to 0
    works fine!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. cyberloner

    cyberloner MDL Member

    Sep 19, 2009
    179
    19
    10
    set to 0 ... all metro app won't run i think...