Windows 7 activation and "bootmgr is compressed" error

Discussion in 'Windows 7' started by edzzzy, Aug 24, 2009.

  1. edzzzy

    edzzzy MDL Novice

    Aug 18, 2009
    5
    0
    0
    Hi, all!

    Thanks for great forum and smart members, which wrote lot off good reading :)

    I have problem with windows 7 activation- I can't done it, I don't know why, I have tried all loaders and all software, except slic BIOS, i think i am afraid of that.

    After installing each loader or other program which have available at repository I restart my computer and get an "bootmgr is compressed press ctrl, alt, delete to restart" error, then i put win 7 dvd in PC, boot into CD and make an startup repair then I can boot into windows but it isn't activated.

    I hope someone could and would help me, thank you all in advance.

    P.S.
    Apologies for my bad English :)

    P.S.S.
    Computer specifications below, if you need more info, please ask.




    I have installed this windows 7:
    Operating System Properties
    OS NameMicrosoft Windows 7 Ultimate
    OS LanguageEnglish (United States)
    OS Kernel TypeMultiprocessor Free (64-bit)
    OS Version6.1.7600
    OS Service Pack[ TRIAL VERSION ]
    OS Installation Date2009.08.15.
    OS RootC:\Windows

    License Information
    Registered OwnerEdzzzy
    Registered Organization
    Product ID00426-321-7001157-70270
    Product KeyC43GM- [ TRIAL VERSION ]
    Product Activation (WPA)Required (21 days remaining)


    On this computer:
    Motherboard
    CPU TypeAMD Athlon 64, 2200 MHz (11 x 200) 3500+
    Motherboard NameGigabyte GA-K8N51GMF-9(-RH) (2 PCI, 1 PCI-E x1, 1 PCI-E x16, 4 DDR DIMM, Audio, Video, Gigabit LAN, IEEE-1394)
    Motherboard ChipsetnVIDIA GeForce 6100, AMD Hammer

    BIOS TypeAward Modular
    BIOS VersionF8
    Award BIOS TypeAward Modular BIOS v6.00PG
    Award BIOS MessageGA-K8N51GMF-9 F8
    System BIOS Date09/16/08

    ACPI Table Properties
    ACPI SignatureAPIC
    Table DescriptionMultiple APIC Description Table
    Memory Address7FFF7E80h
    Table Length114 bytes
    OEM IDGBT
    OEM Table IDAWRDACPI
    OEM Revision42302E31h
    Creator IDAWRD
    Creator Revision01010101h
    Local APIC AddressFEE00000h
     
  2. Searinox

    Searinox MDL Junior Member

    Jul 29, 2009
    57
    1
    0
    #2 Searinox, Aug 24, 2009
    Last edited: Aug 24, 2009
    How many harddrives do you have? On a working copy of a Windows system, set it to show hidden and system files. My guess is that your bootmgr is located on a drive that is not C:\ and that drive is compressed. Even if compressed, Windows makes sure it creates an uncompressed bootmgr. However, subsequent operations by a Windows 7 Loader do not, and may end up compressing it. This only happens if the root of bootmgr's location is set to use NTFS compression, and the circumstances are rare as I will state below...

    The most common reason for this is the Windows boot drive being different from the boot drive in BIOS. When this happens, Windows will still install on the hard disk you've selected. However, the bootmgr file gets written to the hard drive defaulted in BIOS. While the Windows partition is explicitly ensured by Windows to stay uncompressed, these checks don't apply to other harddrives.

    To get around the bootmgr compression, once you've found out what drive the file is on, boot from DVD, open a command prompt to the drive's letter and use:

    expand bootmgr temp
    attrib bootmgr -s -r -h
    del bootmgr
    ren temp bootmgr
    attrib bootmgr -a +s +r +h

    Note drive letters may differ in the boot environment especially if your default boot disk is different from the OS location, that may be defaulted as C:\. After that I suggest you check the properties of each drive and uncheck "compress to save disk space" at least for their root.
     
  3. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    56
    60
    make sure the file is not compressed. Its not that it is compressed in a zip sense of the word.

    Go to the file, right click on bootmgr and make sure under advanced "Compress File to save disk space" is NOT checked.
     
  4. edzzzy

    edzzzy MDL Novice

    Aug 18, 2009
    5
    0
    0
    #4 edzzzy, Aug 24, 2009
    Last edited: Aug 24, 2009
    (OP)
    Hi folks, thanks for answers,

    I have 2 HDD's
    The thing is that, when I am into Windows, I open "My Computer" and all is normal, "C" drive is for windows and "D" for files, but when I am booting from DVD it shows that System is in drive "D"

    So, I will try these commands into my drive "D":

    expand bootmgr temp
    attrib bootmgr -s -r -h
    del bootmgr
    ren temp bootmgr
    attrib bootmgr -a +s +r +h


    I can change those drive letters to show them right into booting process?



    Great news, it changed it:

    " HSChronic HSChronic is offline
    Super Moderator

    Join Date: Aug 2007
    Posts: 697
    Rep Power: 3
    HSChronic is on a distinguished road
    Default
    make sure the file is not compressed. Its not that it is compressed in a zip sense of the word.

    Go to the file, right click on bootmgr and make sure under advanced "Compress File to save disk space" is NOT checked. "

    I activated windows with Windows.7.Loader.eXtreme.Edition.3-Napalum and all is working well...

    Maybe we need to place this topic to popular topics, because I spent hours of searching and found a lot people with same problem and unanswered questions...


    p.s.

    How can I make my "Quick launch" bar from dissapearing from taskbar? after 2 or soimetimes 1 restart my taskbar is gone I have tried all available methods in internet, mostly there are that registry tweak and as I remember that is all...

    Maybe someone knows if it is related with my 2 HDD's thing?
     
  5. Searinox

    Searinox MDL Junior Member

    Jul 29, 2009
    57
    1
    0
    No you cannot change how the drives are shown at boot time. The reason why D:\ is C:\ in boot I have already addressed.

    You have this

    HDD1 [contains bootmgr] <- set as default by BIOS <-- appears as C:\ at boot
    HDD2 [contains windows] <-- appears ad D:\ at boot

    HDD1 needs to have all compression options in the root OFF.

    By any chance is one of the hard drives ATA and the other SATA? BIOS allows you to boot only off either one of them. Switch the boot process to default to HDD2 and THEN reinstall Windows and everything will be on the right drive.
     
  6. edzzzy

    edzzzy MDL Novice

    Aug 18, 2009
    5
    0
    0
    yes, one is ATA and one is SATA drive.

    I think only best thing to do is to remove my documents drive, and install fresh windows into other one, i think it is only best solution :)


    How about dissapearing quick launch? any ideas?
     
  7. Searinox

    Searinox MDL Junior Member

    Jul 29, 2009
    57
    1
    0
    Go to BIOS and change the boot mode from IDE to SATA or the other way around then redo what you've tried so many times til now and this time it'll come out right. :) I have no idea about the quicklaunch, it's out of my league. Your boot problem however, isn't. ;)
     
  8. edzzzy

    edzzzy MDL Novice

    Aug 18, 2009
    5
    0
    0
    that will change my boot drive D to C?
     
  9. Searinox

    Searinox MDL Junior Member

    Jul 29, 2009
    57
    1
    0
    Yes it will. That way windows will stop creating bootmgr on the other drive and keep it on your windows drive. BIOS makes C the default boot drive. Your windows drive ISN'T the default boot drive right now. That's why it's D.
     
  10. howley_brad

    howley_brad MDL Novice

    Oct 12, 2009
    24
    0
    0
    i konw this post is old

    hi i know this post is a little bit old but im hoping that someone can help me i made a really stupid mistake and compressed the wrong drive and now i cant boot up my computer at all it tells me hit control alt delete when i do it restarts it says it yet again ...now iv tried popping in the windows 7 rom i have and no go still doesnt work i even tried using a external usb to run the OS and it wouldnt work still comes up with the same error but the usb worked on another computer ( the one im on) can anyone help me ?
     
  11. Siliwangi

    Siliwangi MDL Member

    Aug 11, 2009
    106
    20
    10
    maybe you can try to "uncompressed" your hard drive in other computer ( remove your hard drive and put in other computer you have ) witch running Windows XP or Windows Vista or Windows 7.

    or you can use live boot CD like hiren boot CD ( with mini XP installed on it ) or use UBCDWIN live CD ( search both in google and download one, I recomended hiren boot CD with small size than UBCDWIN )


    *sorry for my bad english :D
     
  12. shampoo

    shampoo MDL Novice

    Oct 27, 2009
    1
    0
    0
    i have registered only to say thanks to you!!!! sos un genio, papa! el que sabe sabe ajajaj
     
  13. Fireblade

    Fireblade MDL Novice

    Oct 30, 2009
    1
    0
    0
    I want to ask a related question: How does the activation need to be done when there are not 2 physical hard drive units, but 2 partitions? (Windows XP on first partition, Windows 7 on second) You can't switch 2 partitions as far as I know in the BIOS, neither in Windows itself.

    Is it possible, in that case? I have tried several options, of which none of them worked. The "bootmgr is compressed" error always returns. :(
     
  14. imsomguy

    imsomguy MDL Novice

    May 23, 2011
    1
    0
    0
    #14 imsomguy, May 23, 2011
    Last edited: May 23, 2011

    I have a counterfiet version of windows. build 7600. i have no windows 7 CD and i cannot get to the command prompt. im not very good with computers but i only have one disk unless you count the recovery disk. will you please let me know how i cant boot up properly and restore my previous OS (vista)? my laptop is a HP pavillion dv6 notebook. i have a recovery file on a floppy but have no where to insert the floppy. also if my friend (the one who put it windows 7 on my computer) still has the file can i plug in the USB and boot from there? if so how would i go about that? Thankyou for taking your time to read this.