Windows 7 activation for Acer One AO751h

Discussion in 'Windows 7' started by evetsnameloc, Oct 8, 2009.

  1. evetsnameloc

    evetsnameloc MDL Novice

    Mar 4, 2008
    I just picked up an Acer One Ao751h netbook for my wife--Intel Atom processor, Phoenix BIOS, 2GB ram. I have been unable to activate Windows 7 on it.

    For my initial try I installed Win7 (32-bit) and then installed 7Loader version 1.6. The installation appeared to go well but when it was finished and I rebooted it was not activated ("30 days left..."). I loaded up 7Loader again and clicked on the "SLIC 2.1" button and, behold, it told me that there was in fact an ACER SLIC 2.1 in the BIOS.

    I then reinstalled, ran 7Loader, clicked on "SLIC 2.1" and let it proceed to install the Acer certificate and installation key. No joy. Still "30 days left".

    I then found a modded bios on this forum with the ACER SLIC 2.1 so I flashed the bios with this. No problem so far. Reinstalled Windows, and then tried the manual method ("slmgr.vbs -ilc etc., etc."). The certificate installed almost instantly, contrary to my past experience on other computers in which it would take about 15 sec to install. The OEM key took about 1 min to install. Still not activated.

    I did this all with security level set to zero, ran all attempts (7Loader, cmd.exe) as administrator. I have been through this whole process many times before on other computers and never ran into a problem.

    Any other ideas of how to approach this? I know that there is nothing wrong with the Windows 7 install files because I had installed it onto an old HP notebook and used 7Loader to activate it. Is there something weird about these Acers that prevents activation?