Windows 7 and wireless adapters.

Discussion in 'Windows 7' started by jabberwocky, Oct 1, 2009.

  1. jabberwocky

    jabberwocky MDL Member

    Aug 28, 2009
    201
    15
    10
    does anyone know of a decent usb wireless adapter (11n)
    that will work with WIN7 without disconnecting every few minutes .
    I have tried 3 different ones ,that all work in vista 32 and 64bit machines .
    but although I can get it to install in 32bit it keeps shutting down often. and the 64bit Win7 wont even install any of them , it recognizes the hardware correctly but refuses completely to see the drivers ,I have tried everything from disk to manually loading drivers but cannot get a dicky bird from any of the adapters within 64bit win7.
    so I am looking for a new usb adapter here in the uk that has legit win 7 drivers that actually work.
     
  2. cartoon_hero

    cartoon_hero MDL Junior Member

    Oct 8, 2008
    60
    1
    0
    strange, i have an old DLink wirless USB dongle that works just fine on my x86 desktop with no error and it installed even without drivers, windows recognized it right away ...
     
  3. Signmeup

    Signmeup MDL Novice

    Jul 25, 2009
    30
    0
    0
    For about 3 months now I've been using a Zonet 802.11g wireless USB with Windows 7 and it has worked perfectly. They also make a "n" adapter.
     
  4. oneextraid

    oneextraid MDL Member

    Jul 29, 2009
    178
    19
    10
    Jabberwocky,

    Be sure that you have the proper drivers for your motherboard. This could cause strange behavior with USB connections.
     
  5. jabberwocky

    jabberwocky MDL Member

    Aug 28, 2009
    201
    15
    10
    I have the latest drivers in each case from the manufacturer they claim to support both Vista 32 and 64 bit .
    I thought that if it worked on vista it should work in win 7 after all its supposed to have better compatability .
    the Zonet 11n device looks good but not available here in the uk.
    I have looked at dozens of usb wireless adapters and have yet to find one that supports windows 7 64bit here in the uk.
     
  6. danny3456

    danny3456 MDL Member

    Aug 22, 2009
    131
    13
    10
    Suspected yours to be environmental not hardware, distance, walls etc. Disconnections of wifi are life unless your are close to the router. I have used wifi since their first generation, Orinoco, and have complained to various ISPs and checked by their technicians, none of them worked. I have finnally gave up and changed to powerline plugs. It is working smoothly. Yours may be due to unstable signals received from the router, try to have better antennas or locate closer to the router. :confused:
     
  7. pauldamo

    pauldamo MDL Senior Member

    Aug 3, 2009
    452
    41
    10
    win 7 + wireless adapters

    i use a 'd-link dir-300'wireless router and have had no problems,did you install in the right order.i have to install with disk the hard wire to modem first,to get a connection to internet,then install the d-link wireless router,i have to do it in a set order or it doesn't install properly.if they come with instillation disks you just have to follow the order that you have to take, for proper installs.i just remembered with each install,i reset the adapter by pushing a little button inside a hole,had to use a little pin and hold it in for 30 secs.
     
  8. jabberwocky

    jabberwocky MDL Member

    Aug 28, 2009
    201
    15
    10
    Obviousely some misunderstandings here , I am using hyperos ,and running 2 installs of vista 1 in 32bit one in 64bit .
    the signal strength for the wireless adapter ?router is showing as 85-90% constantly and I have never seen it worse than 70%.
    the simple facts are that in both Vista intallations the connection is faultless ,never get a dropped connection .
    but in windows 7 I get dropped connections within 10 minutes or so of it becoming idle ,and i have to do a diagnostics and reset to get it back ,this is constant and is hapening on several installs of win 7 (32) and on 2 different PCs. the windows 7 (64bit) wont even load drivers at all . all drivers are the very latest available , and I have tried earlier drivers too.
    I am only interested in the newer (n) type of adapter .
     
  9. Kingkaktus

    Kingkaktus MDL Novice

    Jul 22, 2009
    10
    2
    0
    Hi
    Sounds like a energy saving Problem.

    I Hope you understand what i mean (i have a German Win7)


    Try to deactivate the USB-Energy-Savings in the extended Energy Saving Options
    And look in the Device-Manager under your Network-Adapter in the Properties on the Right-Pane "Energy Management" deactivate the First Box.