Windows 7 Configuration Update Failure, Reverting Changes (Stuck in Loop) Solution

Discussion in 'Windows 7' started by kingedwards, May 16, 2010.

  1. kingedwards

    kingedwards MDL Junior Member

    Mar 17, 2010
    52
    58
    0
    I am a computer tech and have been getting a lot of Windows 7 computers in lately with this issue. I do not know if anyone on this board has this issue or if it has been addressed in the past on this forum, but I thought I would share my findings.

    The issue is when the computer downloads a windows update and has to restart to configure. What happens is that the configuration fails and you get a message stating "reverting configuration", then windows restarts. After restarting, the configuring windows message appears again and fails again hence you get stuck in a never ending loop and windows never boots. :mad:

    There are two solutions provided by M$ that seem to work provided this is actually a software configuration issue cause by windows update. They both require you to boot to safe mode. One option is to restore image for an earlier date and the other is to enter command prompt as admin and run the System File Checker by typing "sfc /scannow".

    Now here is what I have been seeing a lot of... Apparently if your laptop has a memory card reader built in or attached and you do a windows update that requires a restart you may get stuck in this loop (If you leave the memory card in the slot). I have had a ton of people bring their computers and laptops in with this error and all I had to do is remove the memory card and it boots perfectly without configuration failing. It does not seem to be a boot order configuration error, just some glitch when updating windows. I have not been able to verify if it is a certain update that causes this, or if it happens 100% of the time. I only get the computers with issues.

    In summary, if you are pulling your hair out trying to make your computer boot, make sure to remove the memory card before tossing it out the window.
     
  2. Scubainstructor

    Scubainstructor MDL Novice

    Aug 5, 2010
    1
    0
    0
    Remove memory card works!!

    Well I am stumped. I have just done what you wrote above on my Dell XPS M 1530 as it was in a "Failure to configure" loop after the last "critical" Windows update on the 3rd August.

    I wasn't really sure if that would be the problem for me as I only had the plastic card dummy in the port at the time, but just out of curiosity, and the fact that I have been trawling the net for ages for a fix, and that Microsoft STILL havent answered my email, I thought I would try it.

    It worked first time. Why???????

    Thanks a million for that useful piece of information that I am almost certain Microsoft know nothing about, and probably wouldn't be in one of their fixes on KB.....??!! I now have a working laptop until next time....

    Regards

    Simon:)
     
  3. Jonny4911

    Jonny4911 MDL Novice

    Sep 13, 2009
    1
    0
    0
    yes, thats happened twice to me too!
    but never with a memory card installed :(
    especially since one of the laptops didn't even have a reader! :p
    the only way to fix mine, was to do a (quick? -.-) reinstall of windows!
     
  4. Moe19

    Moe19 MDL Novice

    May 2, 2011
    1
    0
    0
    I have been having the same problem. All I did to resolve it was to remove the disc I had in my DVD drive and the updates installed smoothly.
     
  5. ltroonster

    ltroonster MDL Novice

    May 5, 2011
    1
    0
    0
    I've been having this same problem, after much pulling out of hair...stumbled upon your post and thought
    "worth a try I spose" was over the moon when it actually worked!!, Very strange?? you wouldn't think a piece of plastic would matter...but it sure does the trick, had to join up to the this forum pay my gratitude lol, thanks for the little tip,
    & thanks again Kingedwards for sharing that brilliant piece of info great stuff, great forum!!

    sincerely
    Roon
     
  6. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,692
    3,046
    300
    #6 urie, May 6, 2011
    Last edited: May 6, 2011
    @ acrsn, I had same problem on desktop pc had to manually install from within windows computer could not configure updates when booting into windows turned out it was because virus checker was asking for permission and not letting updates install.
     
  7. malcolmrudge

    malcolmrudge MDL Novice

    May 6, 2011
    1
    0
    0
    Windows 7 Update

    Just like to say thank you. I have been pulling my hair out because I could not get Windows 7 to Update.
    I also had an SD card in laptop for backing up MS Money. Removed card and all was fine.
    Regards.
     
  8. zahnoo

    zahnoo MDL Senior Member

    Feb 2, 2011
    387
    35
    10
    This is outstanding info to have! I've got two netbooks with memory cards in their slots that stay there all the time. Over the years, I've had numerous computers just stop part-way through the boot process because a USB flash drive was in a slot, but never a memory card boot problem.

    I'd have never thought of a card being a problem if this thread had never been created ... now I know better! And, frankly, I love having solutions in mind even if I've never had the problem. But I suspect I'll have the problem one day if I live long enough. ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Liebo

    Liebo MDL Member

    Jul 9, 2009
    133
    2
    10
    I found that it is usually .NET 3.5 updates which fail over and over and "revert". If I download the hotfix file directly from the KB article, it fixes it. Noticed it on XP and Vista also... manual install fixed it in all cases I came across.
     
  10. IwantanEOS5

    IwantanEOS5 MDL Novice

    May 12, 2011
    1
    0
    0
    This problem is not limited to memory cards. Removing my My Passport USB backup drive fixed the problem for me.
     
  11. VanjaL

    VanjaL MDL Novice

    May 12, 2011
    1
    0
    0
    I have an Acer Aspire and have been having the same problem. My solution was the reverse - that is the plastic holder for my card reader had popped out - once I replaced it the configuration completed successfully. The problem seems to just revolve around the card reader and or dvd drive! Thank you.
     
  12. Capetowngurl

    Capetowngurl MDL Novice

    Sep 3, 2011
    1
    0
    0
    I hava exactly the same when i reinstalled windows 7 64 bit cuz it was affected by windows update the latest one was last week it attacked my wiifi n now when i reinstalled i try to install sum updates it's stuck and not being able to access to my desktop neither using safe mode or something else i dont have a laptop i have a desktop i have no more hair to pull it out TTTTTTTTTTTT:furious::blowup:
     
  13. RayLuft

    RayLuft MDL Novice

    Sep 14, 2012
    1
    0
    0
    I had a similar problem where the updates would not install. On shutdown, the updates would again be downloaded, and on and on. After reading some of the comments here, I began to suspect that the problem might have something to do with the USB. I'd installed a Canon printer. I unplugged the printer cable at the computer, rebooted to download the updates yet again, and on the second reboot the installations completed and now no problem - yet. Unplug the USB ports at the computer and try again?
     
  14. Infowiz1

    Infowiz1 MDL Novice

    Jul 22, 2013
    1
    0
    0
    Stop loop by removing disc in DVD Drive

    OMG it worked!! I should have known better. Thanks for the heads-up.... Silly disc B-)

     
  15. StarOne

    StarOne MDL Novice

    Feb 17, 2014
    1
    0
    0
    Like if you don't think removing memory card protector can work try. It worked for me and I had little faith it would. Well done!