Windows 7 Install "A required CD/DVD drive device driver is missing"

Discussion in 'Windows 7' started by jmh, Aug 13, 2015.

  1. jmh

    jmh MDL Novice

    Apr 13, 2013
    14
    2
    0
    "A required CD/DVD drive device driver is missing" or "A media driver your computer needs is missing"

    Windows 8.1 and windows 10 Go fine but i do not want to use either one and cannot install windows 7

    Any ideas?

    was working fine on my maximus vii hero but its giving me the ****s on the VIII board

    You guys got any ideas?
     
  2. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,243
    1,157
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jmh

    jmh MDL Novice

    Apr 13, 2013
    14
    2
    0
    thanks for the reply i had seen that earlier, but when i plug in another flash drive it does not show up

    i have tried a few different flash drives, I have a feeling its a usb3 driver or ahci driver its looking for but i cannot seem to install it
     
  4. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,243
    1,157
    90
    I think too, try installation from an usb2 port
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. bleedlikeme

    bleedlikeme MDL Novice

    Jul 24, 2015
    18
    4
    0
    I had this happen to me recently, turns out my USB port was a bit clogged... Try re-inserting the flash drive or try a different port... USB2 perhaps?
     
  6. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,185
    1,169
    90
    #6 Joe C, Aug 13, 2015
    Last edited by a moderator: Apr 20, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,243
    1,157
    90
    Oh yep didn't notice that in request :rolleyes:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. jmh

    jmh MDL Novice

    Apr 13, 2013
    14
    2
    0
    i always install using usb 2.0 port, i have the MAXIMUS VIII Ranger Board is brand new just 4hrs old
     
  9. jmh

    jmh MDL Novice

    Apr 13, 2013
    14
    2
    0
    tried that still same issue i guess ill just use windows 8.1 and be done as that install with no issues
     
  10. MysTikAL3

    MysTikAL3 MDL Senior Member

    Jul 15, 2013
    380
    8,425
    10
    I've had this error/problem on a few PC's in the past...

    Burn your 7 ISO (slow 4x) to DVD and it will install just fine.
    :)
     
  11. jmh

    jmh MDL Novice

    Apr 13, 2013
    14
    2
    0
    well god damn i knew i wasnt going crazt W7 cannot be installed unless you have an optical drive

    dlcdnet dot asus dot com/pub/ASUS/mb/LGA1151/Z170-K/DE164_100_Series_Windows_7_Setup_Guide_print.pdf
     
  12. exe98

    exe98 MDL Novice

    Dec 11, 2013
    22
    6
    0
    #12 exe98, Aug 14, 2015
    Last edited: Aug 14, 2015
    try change in bios to raid/ide ect. or use NT 6.x fast installer
    imo its bug from boot.wim
     
  13. dacrone

    dacrone MDL Novice

    Dec 23, 2013
    7
    2
    0
    That is incorrect. I have personally installed W7 Pro on numerous computers without internal optical drives. Laptops that come with W8.1 but I downgrade them for purposes. Not sure what the issue is, whether its your BIOS settings or a corrupt flash drive, but it is most definitely possible.