Windows 7 Network Problems

Discussion in 'Windows 7' started by dragonfire665, May 5, 2011.

  1. dragonfire665

    dragonfire665 MDL Senior Member

    Sep 17, 2008
    256
    2
    10
    So i have being searching for an answers within all the threads in here, but i must say there are many and few with similar problems like i am having now. I have a Laptop with Home Premium 64bit 7 and a desktop with Ultimate X64 7, also a 32Bit Xp Pro laptop. Now both the laptop 7 and desktop 7 can see within the home-group, network, the XP Pro laptop and i can open all my share folders inside the XP laptop. However, i can not see neither 7 pcs, neither in the laptop or the desktop. Everything is set correctly, i have the firewall set up, the network is visible, there is no password within any of the computers, all share folders are shared and homegroup is set up.

    I just dont get it what is wrong. I have exhausted all my ideas. Does anyone have a though?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. dragonfire665

    dragonfire665 MDL Senior Member

    Sep 17, 2008
    256
    2
    10
    The XP has no firewall not even Windows due to the fact that i barely use that computer for anything. And yes Network discovery is turned on for both 7.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dragonfire665

    dragonfire665 MDL Senior Member

    Sep 17, 2008
    256
    2
    10
    is not that. The XP laptop is not always on. But is funny how the printing from the 7 laptop works directly to my desktop 7 but yet i cant still the the shared folder. I can see all my shared folders within their respected computers, like when i am in the desktop and i go to Network and click on Computer/Name i will see the printer shared, and the folders as the same goes for the laptop 7. And i already checked for malware.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Nimbus2000

    Nimbus2000 MDL Member

    May 5, 2010
    182
    83
    10
    You may want to try this:

    Open the Network and Sharing Center on your Win 7 machines.

    Select "Change Advanced sharing settings".

    Select "Enable file sharing for devices that use 40 or 56 bit encryption". (XP does not support 128 bit encryption).

    You will still need to configure shares and permissions but I think this will get you moving in the right direction :)
     
  5. woebetide

    woebetide MDL Member

    May 28, 2007
    240
    78
    10
    #5 woebetide, May 7, 2011
    Last edited: May 7, 2011
  6. vstahl

    vstahl MDL Novice

    Aug 11, 2011
    2
    0
    0
    I have a similar problem and haven't found a solution in any thread. My home network consists of a wireless Linksys router, a Dell laptop with Windows 7 Enterprise, a Dell laptop with Windows XP, and a new Acer One Notebook with Windows 7 Home Premium. I've set network file sharing on all three pcs. I can see the Acer from the Dell w/ Win7 and vice versa. I can also see the the Dell w/ XP from the Dell w/ Win7. However, I cannot see the Dell w/ XP from the Acer (w/ Win 7). By "see" I mean the pc shows up under the local Network directory as well as any files I've permitted to be shared. I really need to see the Dell w/ XP from my new Acer to be able to share files. Interestingly, I can successfully ping the Dell w/ XP from my Acer, so I know the router is working properly. I also can get Internet access from all 3 pcs.
    In summary, one Win7 pc can see the XP pc, but the other cannot. Is there a solution?
     
  7. blackdeath

    blackdeath MDL Novice

    Jul 7, 2011
    1
    1
    0
    turn off the home group on all of the win 7 computers and run it as work group so it will be compatible with XP. Only win 7 computers work with homegroup, XP doesn't.
    Good luck.
     
  8. dMog

    dMog MDL Novice

    Mar 27, 2011
    4
    0
    0
    i had this issue myself..to get t to work i ended up having to individually share every file and folder i wanted to have accessible with all computers... a quicker fix would be to install windows 7 on your computer now currently running winXP...that is what i ended up doing...down load it from here
     
  9. vstahl

    vstahl MDL Novice

    Aug 11, 2011
    2
    0
    0
    However, I don't have a home group set up on either Win 7 pc.
     
  10. Shenj

    Shenj MDL Expert

    Aug 12, 2010
    1,557
    652
    60
    You should know that XP doesnt play nice with W7 network shares.
    XP doesnt even have "homegroups" just network shares.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Tr3bg0D

    Tr3bg0D MDL Junior Member

    May 8, 2011
    92
    3
    0
    #11 Tr3bg0D, Aug 12, 2011
    Last edited by a moderator: Apr 20, 2017
    1 - Disable/Turn Off Windows Firewalls on all system on the network....only the Windows Firewall. If you use use 3rd party frewall, temporarily turn it off until network is working properly

    2 - On XP, turn off "Use File and Print Sharing" ; On W7, turn off "Use Sharing Wizard. This is found under Folder Options.

    3- Run this Registry file to turn on Administrative Share on all systems on the network.
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
    "AutoShareServer"=dword:00000001
    "AutoShareWks"=dword:00000001
    4 - Make sure each system on the network has a valid Administrative password. It cannot be blank. I usually keep mine all the same on all my computers.

    After a while, you should begin seeing Shared folders on each system. If you do not see them and want to connect to the other system, simply map an Administrative Network drive, like \\<ComputerName\C$
     
  12. dMog

    dMog MDL Novice

    Mar 27, 2011
    4
    0
    0
    try this

    had this same issue with my brothers system...strange that i found this somewhere looking for a fix...run internet time sync on both computers..it turned out that computers cannot share files no matter what you do if they time is not exactly the same on both computers trying to share files...did the sync and then everything was fine
     
  13. dogleg

    dogleg MDL Novice

    Mar 19, 2009
    11
    0
    0
    The easiest way to network W7 and XP machines is to first disable both the HomeGroup entries in Services. Reboot.
    Make sure all computers are set to share and are on the same group ie MSHome or Workgroup
    In W7 go to Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings and ensure Password Protected Sharing is turned OFF, Network Discovery is ON, File and Printer Sharing is ON.

    Copy the Network Setup Wizard from the XP machine - found at C:\Windows\System32\Netsetup.exe to a usb flash drive . Run this on all machines, rebooting after each run before you run it on the next machine. You may have to reboot a couple of times and/or run the Wizard more than once but it will work. Never failed me yet.