Windows 7 on USB-HDD

Discussion in 'Windows 7' started by beatfreak, Jul 16, 2010.

  1. beatfreak

    beatfreak MDL Novice

    Jul 16, 2010
    7
    0
    0
    #1 beatfreak, Jul 16, 2010
    Last edited: Jul 22, 2010
    Windows 7 on USB-HDD changed: Daz's 1.8.9 loader and GRUB4DOS

    Hello

    i managed to put w7 on a usb hdd and run it from there with no internal/direct connected hdd.
    i had to to this because i'm running it on a netbook in my car, the netbook (PB EasyNote XS20) originally has a 30GB Seagate Lyrion 1.8" HDD witch is... lets say cute :p... and runs on WinXPH

    my usb hdd has 4 primary partitions:
    0 FAT32 containing BartPE and GRUB4DOS (grldr started via ntldr as working bootloader)
    1 NTFS containing WinXP Pro (booted via ntldr in partition 0)
    2 NTFS for Data
    3 NTFS containing Win7 (booted via GRUB4DOS chainloading bootmgr)

    i used grub4dos because loading bootmgr in part3 via ntldr of part0 (mbr) didn't seem to work...
    BartPE is only used for maintenance

    so if i want to start w7 i switch on the machine, ntldr boot menu, select grub, default entry in menu.lst is find and load bootmgr, booting bootmgr from hd0,3...

    running from usb hdd? how?
    in short words: manage to load usbhub and stor drivers earlier and put your usb hdd controller into the critical devices database... see winusb.com its nearly the same way for w7...

    now the problem..
    i tried to install daz's loader (v1.7.7) but got an error "unable to achieve required system access"
    its the same with every of the available "install modes"
    on my main laptop (asus m51vr) this loader worked just fine...

    EDIT: W7 was first installed to a internal pata hdd, then the partiton was copied to the usb hdd and the reg hive edited to get it starting up... this way any kind of mbr or partiton boot code got lost and as w7 is loacted on the fourth partition i had to use grub4dos to boot it.. (before it ever had seen any "activation-loader")
     
  2. WinFLP

    WinFLP MDL Senior Member

    Nov 18, 2009
    499
    281
    10
  3. beatfreak

    beatfreak MDL Novice

    Jul 16, 2010
    7
    0
    0
    #3 beatfreak, Jul 22, 2010
    Last edited by a moderator: Apr 20, 2017
    (OP)
    sorry, couldn't find anything like nt6x fast installer...
    but the installation of win7 isn't the problem..

    as i heard that earlier loaders were booted via a small grub, some kind of "hard manual" installation might work for me...


    EDIT:
    some good and bad news, first the good one...
    now i treid Daz's loader 1.8.9 and it instaled fine :) (without errors, checked the option to preserve the original boot code) so i suppose the activation will work...
    and now the bad news: W7 won't boot anymore :/, as i said i am using grub4dos (v0.4.4) to chainload bootmgr on hd0,3 and now grub4dos stops with an error "invalid or usupported executable format"
    here is the current menu.lst entry:
    Code:
    title BOOTMGR
    find --set-root --ignore-floppies /bootmgr
    chainloader /bootmgr
    
    after the installation of the loader there is a bootmgr and bootwin file, i assume that bootwin is the old bootmgr and the new bootmgr file is the loaders own grub witch applies the slic "patch" at boot time..

    so, now it seems that i only need a way to boot the new loader-bootmgr
    perhaps via an entry in boot.ini (as it is processed first)
    or do i have to modify my menu.lst..?

    i tried also to copy the new created bootmgr to my first partition and load it via boot.ini (C:\bootmgr ...) and guess what, it started my pre-existing grub4dos menu...^^
    so it seems that i have to load grub4dos via grub4dos..? :p

    if i use my first installed grub4dos to chainload the bootwin file that was created it boots win 7 but without the slic "patch" enabled...
     
  4. jusilusi

    jusilusi MDL Novice

    Jun 28, 2009
    39
    0
    0