Windows 7 waking from hibernate

Discussion in 'Windows 7' started by rab2, Dec 1, 2009.

  1. rab2

    rab2 MDL Novice

    Jun 24, 2009
    27
    0
    0
    I've put windows 7 on a fairly old machine of my Dad's, though it runs quite happily. To save him time booting I tried to get him to use hibernate (which he hadn't used on this machine previously (with XP)).

    However, the machine regularly wakes itself up. I've disabled wake for all the hardware that supports it in Windows (keyboard and mouse), not that I think they would wake it from hibernate. I've also disabled all wake options in the bios. Still it does it.

    Any ideas?
     
  2. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    There is a known bug regarding hibernation in win7. It's actually one of the few known bugs in win7.

    Don't know if this is related to it, though, if u disabled wake up for LAN,keyboard and mouse, it seems like it is.

    No apps sheduled for certain tasks ? like torrent app, AV or downloadmanager ?
     
  3. JAHL

    JAHL MDL Novice

    Nov 4, 2009
    28
    0
    0
    you can run this dos command :

    powercfg -h off

    If you want get back run powercfg -h on

    Or maybe a feature in your Bios in enabled and do that.

    JAHL.
     
  4. rab2

    rab2 MDL Novice

    Jun 24, 2009
    27
    0
    0
    Yeah, been through every single device in device manager to see if it had the wake option, and unticked all that did. No apps scheduled afaik (i.e. it's a clean install + office, firefox & thunderbird).

    I wasn't sure that windows/apps could make it wake from hibernate, because it's really off (unlike suspend), so I was leaning toward the bios, except that it never wakes from off off, just from hibernate off, so I'm really not sure. It's a puzzle.
     
  5. Michel

    Michel MDL Expert

    Jul 29, 2009
    1,710
    124
    60
    This problem i have when i am using sleepmode only, dont know how to fix this.
     
  6. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    I'd say it has something to do with the bug that has been reported many times.

    I've experienced that bug too. It's when you have hibernate enabled, after a long time of inactivity the screen will go blank and the pc won't react anymore. Not to mouseclicks, not to keyboard input, nothing. Reset or hard boot is the only option.

    Apparently there are more than a few things wrong with the feature in win7, that need to be addressed in upcoming sp1.

    Don't get me wrong, it could be caused by something else depending on your configuration, but as your issue is allready backed up here by Michel, it seems like it's caused by the same bug.

    gen
     
  7. NodBox

    NodBox MDL Novice

    Oct 6, 2009
    4
    0
    0
    Have you disable allow wake up timer?

    By windows 7 default, its set to enable afaik. Its located under sleep in advanced power settings.
     
  8. rab2

    rab2 MDL Novice

    Jun 24, 2009
    27
    0
    0
    Wasn't aware of that setting. I've disabled it and will try hibernating again and see what happens. Thanks.
     
  9. Michel

    Michel MDL Expert

    Jul 29, 2009
    1,710
    124
    60
    That option is turned on, guess thats the problem.
     
  10. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    Don't know why, but I have that disabled (??)

    Must have done that some time ago...
     
  11. naseap

    naseap MDL Senior Member

    Jul 25, 2009
    488
    123
    10
    I had a similar problem when putting the computer in sleep, hibernate or shut down mode the computer would come back on after a few seconds. I also had the problem of having to do a hard reboot. I fixed the problem by removing the cmos battery from the MB for at least 10 mins. Give that a try because that worked for me. I was going crazy trying everthing until I stumbled upon this fix in another forum.
     
  12. NoGoodNick

    NoGoodNick MDL Novice

    Aug 24, 2009
    19
    0
    0
    I was wondering about that. It only seems to happen occassionally so I didn't put too much weight behind it. Now I know what's causing it.
     
  13. Steamer

    Steamer MDL Novice

    Jul 15, 2009
    12
    0
    0
    This doesn't happen to me on Hybrid.. but randomly does on hibernate, so I disable Hibernate and will stick to Hybrid Sleep until its resolved. Pretty odd.
     
  14. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    I had a similar issue to that only whenever I try to put my pc into either standby or hibernation it wakes up instantly. Turns out I only had to change a pin on my MoBo from S1 to S3. This is not in my bios.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    You don't have a jumperfree mode in bios ? It'll let you configure your bios no matter what position your jumpers are in...
     
  16. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    There is an option for that but it depends on the jumper strangely. I am not sure with that, I left it on Auto and used the jumper.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. naseap

    naseap MDL Senior Member

    Jul 25, 2009
    488
    123
    10
    The only thing that worked for me was to remove the cmos battery. Using the jumper only on the MB did not work. It was only when I removed the battery that it fixed my problem.
     
  18. rab2

    rab2 MDL Novice

    Jun 24, 2009
    27
    0
    0
    It's probably an ASUS board, I have one of those in my own PC. The jumper selects the power rail for the 5v supply for USB devices (between one that is enabled in standby and one that isn't). If it's in the wrong setting it wakes straight up.
     
  19. Michel

    Michel MDL Expert

    Jul 29, 2009
    1,710
    124
    60
    Well i have a Gigabyte board and for me it does awake after a few hours. I didnt turn off the ''allow wake up timer?'' setting and will do that later for testing.
     
  20. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    I have an ASUS P5B, never encountered that issue...
    Have always used jumperfree mode.