Windows 7 x64 explorer.exe GROWING memory usage!

Discussion in 'Windows 7' started by tomisa, Jul 24, 2009.

  1. tomisa

    tomisa MDL Novice

    Jul 19, 2009
    7
    5
    0
    When I start the computer, explorer.exe takes about 100MB of memory and it starts eating more memory right away (even if no programs open and I don't use the computer). About 200KB in every 2 seconds! When my computer had been open for about 6 hours, the explorer.exe was eating memory almost 1GB! Have anyone else noticed this?
     
  2. stimey

    stimey MDL Member

    Apr 21, 2008
    169
    5
    10
    My explorer is 28mb after a few hours of usage. I guess something else is wrong with your install, malware, virus, aliens, MS employees using backdoors to download your porn, etc, etc, etc
     
  3. footgay

    footgay MDL Member

    Jun 28, 2009
    102
    0
    10
    Screenshot, please.
     
  4. Lenmaer

    Lenmaer MDL Addicted

    Jul 3, 2009
    579
    3
    30
    Seems you have some programs running in the background who's eating your memory with explorer.exe
    My guess or maybe a corrupted/bad install.
     
  5. tomisa

    tomisa MDL Novice

    Jul 19, 2009
    7
    5
    0
    The screenshot from explorer.exe

    Here it is!
     

    Attached Files:

  6. tomisa

    tomisa MDL Novice

    Jul 19, 2009
    7
    5
    0
    My laptop is Lenovo T500 2082-53G and I have also installed those beta drivers for win7 from lenovo. Maybe they are the reason for this? Any tips how can I start solving this?
     
  7. Lenmaer

    Lenmaer MDL Addicted

    Jul 3, 2009
    579
    3
    30
    We need a full screenshot of your taskbar, showing evertyhing that is running, also if you have some window open and what kind of.
     
  8. PrEzi

    PrEzi MDL Addicted

    Aug 23, 2007
    534
    3
    30
    Would be also good to attach a hijackthis report.
    Do you have any AV running ? If so - what is the brand ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Lenmaer

    Lenmaer MDL Addicted

    Jul 3, 2009
    579
    3
    30
  10. tomisa

    tomisa MDL Novice

    Jul 19, 2009
    7
    5
    0
    Found the program which is causing that!

    It's that lenovo's access connections toolbar which is causing the explorer.exe to grow.
     
  11. PrEzi

    PrEzi MDL Addicted

    Aug 23, 2007
    534
    3
    30
    Then it has some serious memory leaks. It's a good reason to write an error-report to the support team... Doubt it will help but mayyybe in the future they'll fix it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. Lenmaer

    Lenmaer MDL Addicted

    Jul 3, 2009
    579
    3
    30
    Do you need it? If not don't start it.
    Maybe it's not made for a 64 Bit OS also, I've some 32 Bit app which I cannot run on Vista 64 because they're eating away my memory, but works great on Vista 32.
     
  13. tomisa

    tomisa MDL Novice

    Jul 19, 2009
    7
    5
    0
    Yep closed it already because I don't need it. Reported it already to lenovo community. Thanks everyone!
     
  14. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    57
    60
    Yeah I had a similar issue with the Dell Wifi utility, I was lazy and decided to use setup.exe to load the driver not the INF, and it was causing memory leaks like a mofo.