Windows 7 X64 Explorer slow

Discussion in 'Windows 7' started by superleeds27, Nov 3, 2009.

  1. superleeds27

    superleeds27 MDL Member

    Nov 24, 2007
    129
    4
    10
    When am browsing through my hard drive, i double click on a folder, and its not instant like it use to be.

    It seems to take a fair few seconds for it to open.

    ANyone have the same problem, or any ideas why its doing it?

    I constantly dewfrag, so i know its nothing to do witht hat.
     
  2. imatrix

    imatrix MDL Guru

    Jul 29, 2009
    2,436
    251
    90
    i am running x64 here, no lagging here.
    what antivirus/internet security are you running there?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. superleeds27

    superleeds27 MDL Member

    Nov 24, 2007
    129
    4
    10
    KIS 2010, 9.0.0.736

    Fully Windows 7 Compatible.

    Quite a noticeable slowdwn on hard drives.
     
  4. gentoo

    gentoo MDL Senior Member

    Oct 6, 2009
    394
    8
    10
    I would look for software or hardware issues. Anti virus software can cause it. Also check your hard drive, cpu and memory. Why do you defrag constantly? Windows 7 does it for you on the fly. Defrag is very harsh on your HD and over time will decrease performance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60

    And that is your culprit. AVG shows the same slowdown in explorer.
    So does KIS. It is well known for it.
     
  6. superleeds27

    superleeds27 MDL Member

    Nov 24, 2007
    129
    4
    10
    Kaspersky are currently working on a hotfix, just found out on their forums
     
  7. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,707
    3,064
    300
    Check your power plan settings

     
  8. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60

    Seems really unlikely. This issue is very transparent, as i've come accross it many many times, even goes back years, right to the years of xp.
    AV's have a well known history of slowing explorer browsing down significantly, when monitoring the files you access.
     
  9. bambara

    bambara MDL Junior Member

    Oct 18, 2009
    92
    1
    0
    Remember safe-mode? It's good for troubleshooting.

    Go into safe-mode and see if the problem still persists. If it's gone, then you know that one of the services/drivers disabled during safe-mode causes it.

    It's worth mentioning that I experienced similair issues when I changed some settings my BIOS Setup (I was experimenting). When I reverted back to default setting the problem was gone.

    Another thing, go to Start >> type "Index" >> Click Indexing options>> make sure that only the necessary files are indexed. The process of indexing can be quite a burden on your HD if there's a lot of things to index. If you don't search for files often, I advise you to disable it.
     
  10. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    Agree on the indexing. Have it turned off also. And it does make a difference. Still think it's KIS causing your issue though...
     
  11. burfadel

    burfadel MDL EXE>MSP/CAB

    Aug 19, 2009
    2,628
    3,839
    90
    One cause of lag occurs when Explorer extracts information from each file. If you go to a more simplistic folder view to suit your needs and apply it to all folders of the same type through folder options it could help resolve your issue.
     
  12. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    No it wouldn't. It's simply bypassing and ignoring it. Not resolving it. He should be able to use any folderview without the slowdown. I still say, uninstall KIS and try another, lighter AV. You'll see that the slowdown has gone away. Had to do that myself with AVG.
     
  13. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,707
    3,064
    300
    i still think it is to do with power plan settings
    , even when running xp, i could go from floder to folder in explorer in windows 7 you go to browse one folder, and hard drive kicks in because of power plan settings never had that in xp hard drive was ticking over all the time.
     
  14. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    #14 genuine555, Nov 3, 2009
    Last edited: Nov 3, 2009
    That would happen only when accessing a folder on the drive the first time after non-active state.
    The way he explaines, looks to me that it happens all the time. And that's KIS interfering. Everytime u access a different folder, not only after a certain period of non-activity.

    I'm beginning to seriously repeat myself here :rolleyes:
    But AVG Security Suite has the same slowdown in explorer. Everytime when accessing a folder, there's a 3 to 5 second delay before it opens. Sometimes even longer, depending on the amount of files stored in that folder.
    When i removed AVG and installed nod32, the issue was forever gone. So will it be for KIS also. I am 100% certain of this.
     
  15. PhilNE

    PhilNE MDL Novice

    Sep 13, 2007
    1
    0
    0
    Thanks genuine555..... you are right.
    I had exactly the same problem & have just uninstalled KAV and explorers now back to normal.
    I'm off to Nod now
     
  16. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60

    There you go ;)

    Glad it has helped...