Windows 8.1 apps don't work

Discussion in 'Windows 8' started by sanya353, Nov 20, 2013.

  1. sanya353

    sanya353 MDL Novice

    Jul 5, 2013
    35
    4
    0
    #1 sanya353, Nov 20, 2013
    Last edited: Nov 20, 2013
    My problem is when I launch some apps e.g. Mail, I can't synchronize it. Or when I launch the Bing Weather app I can't click anything. It worked everything a couple of weeks, but I have this problem a couple of days now. It happend earlier, but then it worked a couple of days, but now it's not working again.

    (Sorry for my bad english)
     
  2. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240
    did you sync the store ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sanya353

    sanya353 MDL Novice

    Jul 5, 2013
    35
    4
    0
    How you mean? I updated all my apps.
     
  4. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,146
    240
    run the following in a Command Window to re-register the Store app:
    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    can help you but is just a try
    dunno if this is for your problem but was for several in the past
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. sanya353

    sanya353 MDL Novice

    Jul 5, 2013
    35
    4
    0
    I itried but still not working.
     
  6. pun

    pun MDL Senior Member

    Oct 19, 2013
    465
    188
    10
    I had the same problem. After looking everywhere I still found nothing to help. So just as a last resort, I did a system refresh and everything was solved.
     
  7. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,856
    3,958
    180
    Uninstall the broken apps, goto C:\Program Files\WindowsApps and delete anything left over from them

    Then reinstall them

    I fixed XBOX Games and Mail doing that when a reinstall was not enough
     
  8. sanya353

    sanya353 MDL Novice

    Jul 5, 2013
    35
    4
    0
    I think I know what was the problem. I used a watermark remover and because of that some apps didn't workd. Now I restored the files and it's working.