Windows 8.1 - Marvell Sata Raid Drivers?

Discussion in 'Windows 8' started by staveley, Sep 8, 2013.

  1. staveley

    staveley MDL Novice

    Oct 7, 2007
    10
    4
    0
    Hi Guys,
    I have the Marvell sata ports on my GB Z77X-UD5H mobo configured as a raid1 array & have no problems with Win 8 x64. When I run Win 8.1 x64 setup (clean install) the array is not seen and attempts to load the preinstall amd64 driver (v.1.2.0.1032 or 1.2.0.1038) fail with a compatibility error. I have also tried loading the drivers from the Win 8.1 USB flash drive via an autounattend.xml file but this just hangs. Once Win 8.1 is running, I can add the drivers via device manager & the array is then detected, assigned drive letters and seems to work normally.

    To avoid having to manually reassign drive letters post install, I'd really like to get the preinstall working. Has anyone had any success with these drivers or know of a way of doctoring the .inf files ????

    Thanks.
     
  2. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,787
    10,376
    210
    I would highly recommend against doctoring the files.
    You should probably check some GB forums or support sites and see if they have any beta drivers going.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,759
    1,962
    210
    You may should also try to set the driver to Windows 8 or even Windows 7 Compatibility Mode.

    If I had such problem, that would be my first choice!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Gmas79

    Gmas79 MDL Novice

    Jan 16, 2012
    26
    10
    0
    #4 Gmas79, Sep 8, 2013
    Last edited by a moderator: Apr 20, 2017
    If installation successfully finished and you can add the drivers via device manager, works normally, why not just leave it as. Not big issue, i think. How many times you have to re-install your system a day?
    If you really want, you can try integrate your drivers into offline image using dism.exe.
    Commands should be something like this
    Code:
    
    Image mount
    -----------
    DISM /Mount-Wim /WimFile:D:\install.wim /index:1 /MountDir:D:\Mount
    
    Single
    ------
    Dism /Image:D:\Mount /Add-Driver /Driver:D:\Drivers\xxxxxx.inf
    
    Multiple
    --------
    Dism /Image:D:\Mount /Add-Driver /Driver:D:\Drivers /Recurse
    
    Unsigned
    --------
    Dism /Image:D:\Mount /Add-Driver /Driver:D:\Drivers\xxxxxx.inf /ForceUnsigned
    
    Check
    -----
    Dism /Image:D:/Mount /Get-Drivers /all
    
    Unmount image
    -------------
    Dism /unmount-WIM /MountDir:D:\Mount /Commit
    
    
    Good luck