Windows 8.1 Missing files for restore to factory

Discussion in 'Windows 8' started by KutuluKid, May 14, 2015.

  1. KutuluKid

    KutuluKid MDL Novice

    May 14, 2015
    Hi. First post in this forum, so here goes. I have an Asus laptop I bought brand new which came preloaded with 8.0 and is now on 8.1. I was going to do a system restore, but am getting a error that there are files missing. I even tried rebooting into safe mode, same error. I am just out of my warranty and unfortunately never set up a restore point. I know better, just never got around to it because of time (fulltime job, fulltime college). I did learn how to find the spp folder and have backed it up to an external drive.
    First question, can I d/l a iso of 8.1 and install or does it need to be 8.0 since that is what was originally installed?
    Second question, does it matter if it is just a plain Windows install disc since it was originally preloaded with Asus bloatware as well? I have little experience with 8.+ and am unsure what is needed to use my key and keep things legit. I am pretty sure that you have to have the same hardware configuration (which I do). Thanks in advance to all.
  2. genet

    genet MDL Novice

    Mar 10, 2013