Windows 8.1 (Update 1) using half of available system RAM

Discussion in 'Windows 8' started by doggie015, Apr 18, 2014.

  1. doggie015

    doggie015 MDL Novice

    Aug 12, 2012
    10
    0
    0
    As it says on the title the OS is using 2 GB of RAM so I initially suspected a faulty SODIMM module. However CPU Z is showing that 4 GB of RAM is installed. I would post a screenshot but...

    I already checked in MSConfig and it won't allow me to set more than 2GB of RAM to boot with. What is going on here and how do I fix it?
     
  2. EFA11

    EFA11 Avatar Guru

    Oct 7, 2010
    8,796
    6,750
    270
    did you install an x86 version of windows? is your system x86? the most you can get from an x86 is 3gb (approx). Is your video card or something using 1gb ram?
     
  3. doggie015

    doggie015 MDL Novice

    Aug 12, 2012
    10
    0
    0
    It's an x64 OS and system with 1GB dedicated graphics memory. I just swapped the modules around (Same slots as before) and Windows is now using the full amount.
     
  4. Mr.X

    Mr.X MDL Guru

    Jul 14, 2013
    5,682
    13,107
    180
    Really weird thing...:eek:
     
  5. FCM168

    FCM168 MDL Junior Member

    Mar 27, 2008
    69
    34
    0
    Not really weird, this same thing has happened to me. Windows was seeing 8GB of 12 GB installed. Had to play musical chairs with the RAM sticks and 12 reboots (12 reboots because I installed one at a time) later Windows saw all the RAM installed.

    I thinks Windows 8.1 has issues somewhere as this never happened with Windows 7 or Windows 8.

    Regards
     
  6. EFA11

    EFA11 Avatar Guru

    Oct 7, 2010
    8,796
    6,750
    270
    that was my next suggestion. first wanted to be sure you had x64. I do that all the time, just recently added 4x8GB sticks and had 24GB mem, switched them had 16GB lol switched one more time and had 32. It was my fault though, I took the 2 packages of memory out of the containers and piled them together and lost track of the 2 sets and what 2 belonged to each other.
     
  7. rami7250

    rami7250 MDL Junior Member

    Mar 12, 2014
    55
    3
    0
    I think microsoft have some memory problems. In my laptop it says it use 25% from CPU while i dont use anything.
     
  8. smlm17

    smlm17 Guest

    Hi, but the problem is memory or processor usage?
     
  9. SpeedDream

    SpeedDream MDL Addicted

    Feb 20, 2012
    620
    121
    30
    8.1 32 bits using only 300 megs of ram, beats anything i saw
    the problem is actually module+memory bank or mobo compatibility
    mobos can be a pain in the neck with ram modules, specially where they aint dual channel kits

    suggest you test ram after all this with windows memory diagnostic tool, if there are problems,
    loose the latencies to the slower module

    cheers, hope it helps
     
  10. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,724
    1,952
    210
    It could also be an problem of cheapo module sockets!! In most cases I really believe, it's just the hardware! In my company we always using soft pencil rubber to 'clean' the connector 'feets' of the memory modules and also using medical alcohol (NOT rubbing alcohol, the light blue one) with an soft toothbrush for to clean the module sockets inside. That help's in most of the cases very well. Also moving the memory module a bit from side to side, while trying to center them, at inserting the memory module to the sockets. There's always a bit space for to moving and the the connectors on the modules are very narrow so the connector from socket could 'short' two of the 'feets' of the modules!

    One isn't to blame and that's the OS!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. generalmx

    generalmx MDL Novice

    Apr 15, 2014
    34
    20
    0
    If the OP were to have used something like resmon (included in Windows) or RAMMap (Sysinternals, download from Microsoft's site), they would've seen most of the RAM is being taken up by "Hardware Reserved" or otherwise not really available to Windows itself: when there's a problem with memory-mapping -- like with a bad memory config -- it gets thrown in there. I've had that happen before with memory sticks that weren't all from the same kit, but the BIOS reported the correct amount fine (I just scrambled their module order until it worked).
     
  12. warlordll

    warlordll MDL Member

    Apr 25, 2011
    231
    23
    10
    have you tried moving the ram sticks around to other channels? i had same problem yesterday when i took mine out to test memory leaks and stuff it showed 4gb of 16gb