Windows 8 entering sleep on its own

Discussion in 'Windows 8' started by 100, Dec 7, 2012.

  1. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,544
    60
  2. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,143
    240
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,544
    60
    No, the issue in this case is that disabling automatic sleep has no effect. That's what the setting is already set to.
     
  4. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,143
    240
    ok, was a try.
    Where comes the "order" from? Bios?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Shenj

    Shenj MDL Expert

    Aug 12, 2010
    1,557
    652
    60
    If you only get this issue currently only on wakeup via Mouse/Keyboard then disable "allow this device to wake the computer" for both in Device Manager, so at least you don't come across the bug accidently for now.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,544
    60
    It comes from the OS due to "system idle", which shouldn't happen when idle timeout is disabled.

    Yup, that's what I'm doing for now.
     
  7. Kris78

    Kris78 MDL Novice

    Dec 28, 2012
    3
    0
    0
    #7 Kris78, Dec 30, 2012
    Last edited: Dec 30, 2012
    from above information:



    Lenovo V570 Laptop with external Logitech mouse on dongle

    uncheck:
    Device Manager / Keyboard / HID keyboard device / Allow this device to wake the computer
    Device Manager / Mice and other pointing devices / HID compliant mouse / Allow this device to wake the computer
    Device Manager / Mice and other pointing devices / Logitech HID-compliant mouse / Allow this device to wake the computer


    No more 2 min sleeps, and can wake up with laptop keyboard.
     
  8. laqk

    laqk MDL Novice

    Jan 22, 2011
    45
    33
    0
    #8 laqk, Dec 31, 2012
    Last edited by a moderator: Apr 20, 2017
    Had the same problem on my HP laptop. This is a USB mouse/keyboard issue only. Waking with PS/2 mouse/trackpad/keyboard works fine. From what I can tell, this is the result of a poorly written DSDT in the ACPI tables. I solved the problem with a DSDT edit, and using a bootloader that allows me to specify my own DSDT on boot.

    In most DSDTs you'll find a number of _Lxx statements like the following to handle USB wake events for each USB port:

    Code:
            Method (_L03, 0, NotSerialized)  // _Lxx: Level-Triggered GPE
            {
                Notify (\_SB.PCI0.UHC0, 0x02)
            }
    Where UHC0 is a USB port declared somehere else in ACPI namespace. If you make the following modification for each USB port that can wake the system:

    Code:
            Method (_L03, 0, NotSerialized)  // _Lxx: Level-Triggered GPE
            {
                Notify (\_SB.PCI0.UHC0, 0x02)
                Notify (\_SB.PWRB, 0x02)
            }
    the problem will be solved (PWRB is the Power Button device). Yeah, it's ugly. But it works. And by the way, if you look at DSDTs from Apple laptops, you'll see that that's how they solve the problem also, i.e. Apple laptops would also exhibit this problem, if it weren't for this hack.
     
  9. user_hidden

    user_hidden MDL Expert

    Dec 18, 2007
    1,026
    982
    60
    @100

    I have sleep set to "never" in the power options and my system does not sleep so I am not experiencing your issue.
    when sleep was enabled when the system wokeup I always lost Ethernet device hence no internet, was a pain!!
     
  10. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,544
    60
    Interesting. So what this does is mask the USB wake event by triggering a "power button" event instead? What are the applications you're using to edit and override the system DSDT on boot?

    Still, this looks more like an OS power management issue. Windows seems to use an imaginary idle timeout period to trigger a power state change in this case, and that's clearly not the correct way to handle that. I hadn't noticed this issue before Windows 8.

    The specific issue here seems to only be related to USB wake events. Sleep/wake for works just fine, unless waking is done by USB.
     
  11. laqk

    laqk MDL Novice

    Jan 22, 2011
    45
    33
    0
    Well, yes and no. Actually, it adds another wake event.

    Oh it's definately an OS power management issue. But at the root of it is a bad DSDT, probably a bad _WAK method. If you get the chance to study a few samples of ACPI tables on various BIOSes, you'll quickly realize that the vast majority of them are incredibly buggy. In fact OSes like Windows and various Linux flavors have to take that into account, and they usually do. My guess is someone at Microsoft didn't do his/her job right and let an old bug slip in the W8 code, a bug that's probably been corrected long ago in W7 and Vista by a service pack or a patch.

    I use Clover. It's a bootloader used to run OS X on non-Apple hardware. It allows to use custom ACPI tables instead of the ones in the BIOS. At some point, by popular demand, the developers added the possibility to use a custom DSDT when booting Windows as well. As for editing ACPI tables, I use the standard tools available on the acpica.org website, mainly iasl.
    But technicaly, you don't need a bootloader with ACPI override. You can always correct the tables and reflash your BIOS... if you got the nerves... :D