windows 8 internal HDD-s recognized as removable device

Discussion in 'Windows 8' started by bertikul, Aug 24, 2012.

  1. bertikul

    bertikul MDL Member

    Nov 2, 2007
    204
    21
    10
    windows 8 internal drives are recognized as removable device. There is a fix for windows 7:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Controller0\Channel0]
    "TreatAsInternalPort"=dword:00000001

    But it doesn't work for win 8.

    Anyone knows any fix for 8?
    Thanks
     
  2. bertikul

    bertikul MDL Member

    Nov 2, 2007
    204
    21
    10
    nobody has a workaround?
     
  3. badboy77

    badboy77 MDL Novice

    Mar 1, 2008
    23
    2
    0
    in windows 8 they changed msahci, more infomation here msdn.microsoft.com/en-us/library/windows/desktop/hh848066(v=vs.85).aspx

    if not mistaken the msahci reg dont exist more in win8, now is StorAHCI

    hope i helped
     
  4. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,635
    1,915
    210
    It could happen that you've AHCI in Bios enabled. That makes internal HDD's removeable (Hot Plug)

    I use that an all of my machines because I use SATA Hot Plud Cases for the HDD's, that means I could change HDD's without to power down the computer, for sure not Drive C!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. tithitoy

    tithitoy MDL Novice

    Aug 27, 2007
    42
    2
    0
    you config HDD as AHCI, You must install driver for it.

    the fix for windows 7 is enable AHCI host controler in system. but in win 8 its enable as default
     
  6. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,635
    1,915
    210
    In Windows 7 Ultimate the driver for AHCI is installed by default, if: AHCI is enabled in BIOS at the time you install Windows 7. If you do the install later on, you've to change some settings in Registry, No need to install any driver.

    I use AHCI about 6 years now on all computer in my Office and at home.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. bertikul

    bertikul MDL Member

    Nov 2, 2007
    204
    21
    10
    #7 bertikul, Aug 27, 2012
    Last edited: Aug 27, 2012
    (OP)
    thank you all for your replies

    yes I have ahci enabled in BIOS.

    The registry trick for win 7 was used to make windows think the HDD/SSD-s were NOT removable devices. So NO icon in notification area (hiding it doesn't solve the problem, as someone suggested). I did it in win 7 and it works.

    btw I tried the reg file with StorAHCI instead of msahci. It creates the registry keys as it should in -> StorAHCI, but it does not work. Still having HDDs/SSDs showing as removable devices.