Windows 8 startup delay problem

Discussion in 'Windows 8' started by localhost, Aug 7, 2012.

  1. localhost

    localhost MDL Novice

    Nov 16, 2009
    2
    0
    0
    #1 localhost, Aug 7, 2012
    Last edited: Aug 7, 2012
    Hello everyone,
    So, after months of waiting I'm finally migrating to the Windows 8 platform. After I installed all my programs and drivers, covered the Metro bulls**t stuff and so on, I noticed there is something wrong with the startup of my programs.

    No matter if programs are started from the registry or just using StartUp folder, they always have a long delay before they start. So for example, I have to wait about a minute or so to finally get my Logitech SetPoint software working. That's quite annoying, because without SetPoint my scrolling doesn't work they way it's supposed. Not to mention other "needed" programs. I got a SSD drive and therefore my computer is ready to work just seconds after I press the power button. At least that's how it worked in Windows 7.

    So if anyone knows a method to disable this frustrating (unneeded in my case) delay I'd be really thankful.


    Sure they are workarounds, for example putting a task after logon, but I'd have to do that every time I installed a new program that's supposed to autorun.


    Thanks in advance for your tips.
     
  2. roirraW "edor" ehT

    roirraW "edor" ehT MDL Addicted

    Sep 1, 2007
    616
    215
    30
    Simple. Make exactly one scheduled task (read the rest) which runs at Logon but which launches a Batch (.bat) file. Put all your commands in the .bat file and voila. Any new program you want run this way do the same. Just make sure and turn off any other method the programs have to run automatically since then they'll run twice which might, or might not be a problem depending on the program or usage. Remember to schedule it to run as Admin. This should work, right (everyone)?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Mr Jinje

    Mr Jinje MDL Expert

    Aug 19, 2009
    1,773
    1,088
    60
    #3 Mr Jinje, Aug 8, 2012
    Last edited by a moderator: Apr 20, 2017
    The 'delay' is a Windows feature. Your work-around (At least for non UI apps) could be to schedule them at the "Machine/Start Up" stage instead of waiting until the "User/Log On" stage.

    Haven't tried on Windows 8, but I assume the path is still the same.

    Code:
    C:\Windows\System32\GroupPolicy\Machine\Scripts\Startup
     
  4. localhost

    localhost MDL Novice

    Nov 16, 2009
    2
    0
    0
    #4 localhost, Aug 8, 2012
    Last edited: Aug 8, 2012
    (OP)
    Yeah, I had such a clue that this might be a Windows "feature".

    Task scheduler was my first guess as a workaround and of course that works great ;) I had some issues with "Machine/Start Up" so I left it with "User/Log On" for now.


    Is there another method to achieve this same without messing around with startup programs? I'd be pleased if I hadn't to do this with all my programs (and reverse changes in case I uninstalled it). Maybe a simple registry edit or a file patch to disable the delay?


    PS Thank you guys for your advices, much appreciated.