Windows Defender Issues as of late

Discussion in 'Windows 7' started by bcsman, Feb 18, 2018.

  1. bcsman

    bcsman MDL Novice

    Sep 13, 2015
    16
    12
    0
    #1 bcsman, Feb 18, 2018
    Last edited: Feb 18, 2018
    Has anyone had any problems in the last month or so updating Defender definitions on their Win 7 drives? I keep getting errors on 2 different drives, also a new Win 7 install. Has MS maybe dumped Defender so it can't be updated anymore? The normal Windows updates are working fine, it's just Defender. Also must note I have downloaded the manual definition update file and still no love.

    I have an Ultimate and an Enterprise version that are having these issues.
     
  2. Oswego97

    Oswego97 MDL Novice

    May 9, 2016
    1
    0
    0
    Working fine here with Enterprise - last update yesterday.
     
  3. bcsman

    bcsman MDL Novice

    Sep 13, 2015
    16
    12
    0
    Weird, I have tried downloading from MS a fix for Defender and a couple other Windows fix and repair programs but nothing helps. So I just went into Services and disabled Defender. I know for Windows 7 it isn't much of a program anyhow. I do have 2 other computers with Win 7 on them and Defender updates fine. This one is a very old AMD Athlon computer so maybe its just too old to work anymore. I did download and install Panda Free and it is working fine so I will leave it at that.
     
  4. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    21,433
    29,364
    390
    Afaik, Win 7/8 will get a defender update, it will be the same for all windows editions.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. bcsman

    bcsman MDL Novice

    Sep 13, 2015
    16
    12
    0
    I was hoping after my new Win 7 install there was a newer version of Defender I could download but it doesnt look that way. Sometimes older versions of software wont update unless the newer version is installed. As I said no problem, just shut off Defender and installed Panda Free, just very odd behavior, only on that one computer I have, the rest work fine....