Windows Developer Preview (AHCI , Protogon)

Discussion in 'Windows 8' started by Mordheim, Sep 15, 2011.

  1. Mordheim

    Mordheim MDL Novice

    Sep 15, 2011
    5
    5
    0
    So , enabling AHCI consisted just to edit registry key in - HKLM\System\CurrentControlSet\Services\msahci ,but there is no such thing in WDP (8102).
    The most interesting thing for me was a new file system Protogon, but there is no information soo far , anybody tried to enable Protogon on 8102 and find out how it works ? (Last time i tried a Protogon, everytime after BSOD partition was unable to enter)
     
  2. gecebilgisayar

    gecebilgisayar MDL Novice

    Sep 16, 2011
    5
    0
    0
    Teşekkürler
     
  3. Mustafa Can

    Mustafa Can MDL Member

    Jul 6, 2011
    124
    56
    10
    Please speak English =)
     
  4. free1975yuly

    free1975yuly MDL Expert

    Aug 24, 2011
    1,763
    149
    60
    In Turkish means Thanks a lot ....:p
     
  5. Mustafa Can

    Mustafa Can MDL Member

    Jul 6, 2011
    124
    56
    10
    Okay, Thanks we can use Google translate too. :D
     
  6. BrakBrak

    BrakBrak MDL Novice

    Sep 12, 2009
    5
    1
    0
    I could not get Windows 8 installed without turning off AHCI (would always error out at 50%). Afterwards I would have to switch between AHCI on and off to boot back into Windows 7 (which was setup with AHCI) or Windows 8 (which was setup with AHCI off) or else I would blue screen or get an inaccessible boot device error from the Windows 8 boot loader.

    I found a solution/work around so that I could setup Windows 8 and run it in AHCI mode.

    I first set AHCI off for the Windows 8 setup, then immediately after the first boot during initial setup, but before setup continued I set AHCI back on. After setup completed I had Windows 8 running in AHCI mode, hope this helps someone.
     
  7. vajoiner

    vajoiner MDL Novice

    Sep 29, 2011
    3
    2
    0
    ugh. i do NOT want to reinstall all this crap again :mad: to turn ahci on but, using a hackintosh, its really annoying to switch back and forth in the bios. really annoying. i hope your technique works for me or i'm going to freak out.
     
  8. vajoiner

    vajoiner MDL Novice

    Sep 29, 2011
    3
    2
    0
    #8 vajoiner, Oct 8, 2011
    Last edited: Oct 8, 2011
    this worked for me. thank you.
    switch to ahci during the first reboot.
     
  9. JKR

    JKR MDL Novice

    Dec 9, 2011
    1
    2
    0
    1 post wonder, this worked for me:

    1) Go to: HKEY_LOCAL_MACHINE\SYSTEM\HardwareConfig\{5d1d1dc-this will be different for you-3869-f1f57388cca2}\Services\
    2) Delete the entry "storahci"
    3) Restart and change to ahci in the bios
     
  10. proffkom

    proffkom MDL Novice

    Oct 17, 2011
    1
    1
    0
    #10 proffkom, Dec 26, 2011
    Last edited: Dec 26, 2011
    HKEY_LOCAL_MACHINE \ SYSTEM \ HardwareConfig \ {5d1d1dc-this will be different for you-3869-f1f57388cca2} \ Services \ 2) Delete the entry "storahci"3


    it is not necessary to delete and to change a value from 3 on 0

    :biggrin: